はじめに

SafeGuard PrivateCrypto は、データの暗号化に簡単に利用できる手段を提供しています。 単一ファイル および複数ファイルのほか、ディレクトリ全体を暗号化できます。 ディレクトリの構造は、復号化の 後も維持されます。 さらに、ファイルは暗号化の後に圧縮できます。


アーカイブ

複数ファイル (アーカイブ) の暗号化および圧縮もサポートされています。アーカイブに対する単一 ファイルの追加および抽出が簡単に行えます。
SafeGuard PrivateCrypto 1.x は、SafeGuard PrivateCrypto 2.x 以上のバージョンで作成されたアーカイブを 開くことはできません。SafeGuard PrivateCrypto 2.x は SafeGuard PrivateCrypto 1.x で作成されたアーカイ ブを開くことはできますが、変更できません。
Windows エクスプローラとの連動により、Windows エクスプローラでファイルを右クリックし、パス ワードを入力することで、ファイルを暗号化できます。
ファイルの復号化は、単純にアーカイブをダブルクリックしてパスワードを入力するだけで行えます。 あるいは、暗号化に使用した鍵をユーザが利用できる状態になっている必要があります。 ファイルを 復号化するユーザが SafeGuard PrivateCrypto をインストールしていない場合、自己解凍実行可能ファイ ルを作成できます。 これらのファイルの復号化には、パスワードの入力が必要です。
SafeGuard PrivateCrypto User Application を使用すると、ユーザはアーカイブの作成および管理 (ファイ ルの追加/削除) を実行できます。 アーカイブへのファイルの追加は、ユーザ アプリケーションの SafeGuard Private Crypto ファイルにこれらのファイルをドラッグするだけで実行できます。 暗号化/復 号化のデフォルト値 (たとえば、暗号化されたファイルのデフォルト フォルダ) も同じ場所に設定で きます (SafeGuard PrivateCrypto の [オプション] ダイアログ)。


SafeGuard Enterprise 鍵リングの鍵

SafeGuard PrivateCrypto ではパスワードを入力することによってファイルを暗号化するだけでなく、暗号化に SafeGuard Enterprise 鍵リングの鍵を利用することができます。 コンピュータに SafeGuard Enterprise がインストールされている場合、ユーザの鍵リングのすべての鍵 (SafeGuard Enterprise で一元的に作成された鍵および SafeGuard Enterprise クライアントでローカルに作成された鍵) を使用できます。
そのため、SafeGuard PrivateCrypto アーカイブを SafeGuard Enterprise ユーザ間で簡単に交換できます。 アーカイブの復号化では、暗号化に使用した鍵がコンピュータで利用できる状態になっている必要が あります。 この操作には、両方のコンピュータで SafeGuard PrivateCrypto Version 2.30 以上が使用されて いる必要があります。
ヒント:
両方のコンピュータで同じ鍵が利用できる状態になっている必要がある点に注意してください (た とえば、SafeGuard Enterprise グループ鍵)。 受信者の鍵リングに含まれない SafeGuard Enterprise 鍵を 使用すると、受信者はアーカイブを復号化できません。
ローカルで生成した SafeGuard Enterprise 鍵を使用する場合、受信者にパスフレーズを連絡する必要が あります。 受信者は、アーカイブを開くときにパスフレーズを入力するように自動的に求められます。


記録 (パスワード履歴)

暗号化のパスワード、ファイル名、日付およびオプションのコメントが保存されているログ ファイル を生成できます。 このログ ファイルは、追加のパスワードまたは SafeGuard Enterprise 鍵を使用して暗 号化されます。 各暗号化処理でさらにパスワードを入力する必要があるため、レジストリにパスワー ドを保存して、より簡単に行えるようにできます。 ただし、安全な方法でパスワードを保存すること はできないので、この方法はセキュリティ上のリスクが生じる点に注意してください。
暗号化で SafeGuard Enterprise 鍵を使用する場合、使用した鍵がユーザの鍵リングに含まれる場合に限 り、ユーザの介在なしでパスワードが保存されます。


暗号化された電子メールの添付ファイル

SafeGuard PrivateCrypto を使用すると 1 回の操作で電子メールを介してファイルを暗号化して送信でき ます (「[暗号化と送信]」を参照してください)。 暗号化およびオプションの圧縮の後、電子メール ク ライアントが起動し、ファイルが自動的に添付されます。


アルゴリズム

SafeGuard PrivateCrypto は、新規の AES (Advanced Encryption Algorithm) として定義されている "Rijndael" アルゴリズムを使用しています。 Utimaco の実装では、データの暗号化に鍵の長さが 256 ビットの "Rijndael" アルゴリズムを使用しています。 圧縮では、BZIP2 ライブラリが使用されます。 暗号化操作用 の鍵は、PKCS#5 (Password Based Cryptography Standard) を使用して入力されたパスワードから引き出さ れます。
SafeGuard PrivateCrypto は、Windows 2000、Windows XP および Windows Vista で利用できます。 フリー ウェアとしても利用でき、SafeGuard PrivateCrypto ホームページでダウンロードして、個人的に利用で きます (www.utimaco.com/PrivateCrypto.com)。


インストール

PC に SafeGuard PrivateCrypto をインストールするには、sgpc231.exe または sgpc231.msi (ライセ ンスを受けていないバージョンの場合、sgpc231_u.exe または sgpc231_u.msi ) をダブルクリック して、セットアップ プログラムを起動します。 インストール ウィザードに従って、それ以降のインス トール手順を実行します。


SafeGuard PrivateCrypto User Application

SafeGuard PrivateCrypto を起動するには、[スタート] > [プログラム] > [SafeGuard PrivateCrypto]
(またはインストール時に選択したフォルダ) > [SafeGuard PrivateCrypto] をクリックします。
SafeGuard Private Crypto では SafeGuard PrivateCrypto Explorer の拡張機能のほか、Safeguard Private Crypto User Application を使用してアーカイブを作成および管理できます。
アプリケーションでは、アーカイブにファイルを追加したり、アーカイブからファイルを削除したり できます。既存のアーカイブから単一ファイルを抽出できます。
Windows エクスプローラから PrivateCrypto ファイル リストにファイル (およびディレクトリ) をド ラッグできます。 その後、これらのファイルが現在のファイル リストに追加されます。
SafeGuard PrivateCrypto User Application のファイル リストは、現在選択している暗号化アーカイブに加 えられたすべての変更内容を表示します。
ファイルはすでにアーカイブに含まれており、変更されません。
ファイルが暗号化アーカイブに追加されます。
ファイルが暗号化アーカイブから削除されます。
暗号化アーカイブへの変更は、ファイルを保存するときにのみ実行される点に注意してください。
[復号化] ボタンまたはメニュー コマンド ([ファイル] > [復号化]) を使用して、リストで暗号化アー カイブの 1 つまたは複数のファイルを選択し、アーカイブから抽出 (復号化) できます。 ファイルの暗 号化されたバージョンは、暗号化アーカイブ内に残されます。 ファイルが選択されていない場合、デ フォルトで [復号化] コマンドがアーカイブのすべてのファイルを抽出します。
ディレクトリ全体を暗号化する場合、該当するパスが SafeGuard PrivateCrypto User Application のリスト ビューの [パス] の下に表示されます。


SafeGuard PrivateCrypto の [オプション]

SafeGuard PrivateCrypto の [オプション] ダイアログ ([ツール] > [オプション]) で、暗号化/復号化用 のデフォルト値およびパスワード記録の操作を定義できます。 これらの内容は、SafeGuard PrivateCrypto User Application および Windows エクスプローラの拡張機能の両方に適用されます。 必要な 場合、[SafeGuard PrivateCrypto - 暗号化ファイルを保存] および [SafeGuard PrivateCrypto - 復号化] ([オ プション] をクリック) ダイアログで変更することもできます。 デフォルト設定値は、[オプション] ダ イアログ内でのみ変更できます。 [オプション] ダイアログには、3 つのタブがあります。


[暗号化]

インストール後のデフォルト設定値は、次のとおりです。
  • [デフォルト フォルダ]: 空の状態 [ソースと同じ]
  • [自己解凍実行可能ファイルの作成]: 無効
  • [暗号化後にソース ファイルを安全に削除]: 無効
  • [データの圧縮]: 有効
これらの設定値が変更されている場合、[デフォルト] ボタンをクリックして元に戻せます。
ここに定義された設定値はすべての暗号化操作 (SafeGuard PrivateCrypto User Application または Explorer の拡張機能を使用して実行された操作)で有効です。 これらの値は一時的に [シングル 暗号化操作]
([暗号化ファイルを保存] ダイアログの [オプション]) に上書きできます。
[OK] をクリックして設定値を保存し、[オプション] ダイアログを閉じます。


[復号化]

インストール後のデフォルト設定値は、次のとおりです。
  • [デフォルト フォルダ]: 空の状態 [ソースと同じ]
  • [全てのファイルの復号化後、アーカイブを安全に削除]: 無効
これらの設定値が変更されている場合、[デフォルト] ボタンをクリックして元に戻せます。
ここに定義された設定値はすべての復号化操作 (SafeGuard PrivateCrypto User Application または Explorer の拡張機能を使用して実行された操作)で有効です。 これらの値は一時的に [復号化] ダイアログの
[シングル復号化操作] に上書きできます。
  • [デフォルト フォルダ]:
    デフォルトで、このディレクトリにファイルが復号化されます。 ドロップダウン リストでは、ソース ファイルと同じディレクトリおよび My Documents フォルダを選択できます。 [...] ボタンをクリックして、別のディレクトリを選択することができます。
  • [ファイルの復号化後、アーカイブを安全に削除]:
    有効な場合、すべてのファイルが復号化された後、暗号化されたアーカイブが消去され、今後復元できなくなります。
[OK] をクリックして設定値を保存し、[オプション] ダイアログを閉じます。


[パスワード履歴]

暗号化のパスワード、ファイル名、日付およびオプションのコメントを保存できるログ ファイルを生 成できます。 このパスワード履歴は、追加のパスワードまたは SafeGuard Enterprise 鍵を使用して保護さ れます。 このパスワードは各暗号化処理で入力する必要がありますが、レジストリに保存できます。 た だし、安全な方法でパスワードを保存することはできないので、"セキュリティ上のリスク" が生じる 点に注意してください。
パスワード ログ ファイルを表示できる唯一の方法は、[ツール] メニューの [パスワード履歴の表示] コマンドを使用することです。
インストール後のデフォルト設定値は、次のとおりです。
  • [パスワード履歴の有効化]: 無効
  • [パスワード履歴ファイル]: なし
  • [履歴ファイルのパスワードをレジストリに保存]: 無効
これらの設定値が変更されている場合、[デフォルト] ボタンをクリックして元に戻せます。
アーカイブのパスと名前、パスワード、作成日、およびコメントを別個のファイルに保存するには、
[パスワード履歴の有効化] オプションをオンにする必要があります。 履歴ファイルの名前とパスは、 次のステップで指定できます。
便宜上、履歴ファイルのパスワード (アーカイブが作成され、パスワード履歴にパスワードが記録さ れるときは常に入力する必要があります) を Windows レジストリに保存できます。 この方法は、セキュ リティ上のリスクが生じる点に注意してください。
[OK] をクリックして設定値を保存し、[オプション] ダイアログを閉じます。


SafeGuard PrivateCrypto のパスワード履歴

ユーザは、別個のファイルにパスワードを記録できます。 ファイルにパスワードを記録することにした 場合 (セキュリティ上のリスクが生じます)、このファイルを保護するために次の内容を実行できます。

ヒント:
SafeGuard Enterprise 鍵を使用する場合、パスワード履歴の記録が設定されていても、効果はありま せん。 そのため、アーカイブの暗号化に SafeGuard Enterprise 鍵が使用された場合、ユーザはパスワー ドを入力するように求められません。

  • 安全は方法は、必要な各記録操作でログ ファイルのパスワード (暗号化に使用したもの) を入力することです。 常に 2 つのパスワード (アーカイブ用とログ ファイル用) を入力する必要があるため、より安全ですが、ユーザにとって使い勝手が良い方法ではありません。
  • または、パスワード履歴を保護するために SafeGuard Enterprise 鍵を使用できます。 ユーザの個人用の鍵リングに鍵がアクセスできる場合、ユーザの介在なしでファイルが暗号化されます。
  • ログ ファイルのパスワードは、レジストリにも保存できます。 このパスワードは、記録用に使用されます。 ユーザがログ ファイルを表示する場合、再度このパスワードを入力する必要があります。 ただし、この場合、パスワードおよびログ ファイルを保護する安全な方法はありません。
パスワード履歴は、[オプション] ダイアログ ([パスワード履歴] タブ) で有効になっている必要があ ります。
パスワード履歴ファイルの内容を表示できる唯一の方法は、SafeGuard PrivateCrypto User Application の [ツール] メニューの [パスワード履歴の表示] コマンドを使用することです。
アーカイブのパスと名前、パスワード、作成日、およびオプションのコメントは、リストに表示され ます。 [履歴をクリップボートにコピー] ボタンを使用して、履歴ファイルの内容をクリップボードに コピーできます。保存方法に不安がある場合、クリップボードから、ワード プロセッサに貼り付ける ことができます。

ヒント:
履歴ファイルの内容のコピーに使用した後、クリップボードを空の状態にすることを忘れないでく ださい。


新規のアーカイブの作成

SafeGuard PrivateCrypto 内の新規のアーカイブは、次の方法で作成できます。
1.
Windows エクスプローラでファイルまたはディレクトリを選択します。
選択した内容を右クリックし、[SafeGuard PrivateCrypto] ショートカット メニューの [PrivateCrypto] をクリックします。 SafeGuardPrivateCrypto User Application が開きます。
選択したファイルは、SafeGuard PrivateCrypto User Application のリスト ビューに表示されます。
ディレクトリを選択した場合は、[パス] の下にディレクトリ名が表示されます。
[保存] をクリックします。
ここで、パスワードを入力するか、SafeGuard Enterprise 鍵を選択できます。
[パスワード]:
パスワードを入力し、確認してから、[OK] をクリックします。 アーカイブが指定したターゲット ディレクトリに作成されます。
デフォルト設定値 (ターゲット ディレクトリ、オプションなど) は SafeGuard PrivateCrypto User Application の [オプション] ダイアログで設定できます。
[鍵]:
ユーザの SafeGuard Enterprise 鍵リングから任意の鍵を選択できます。
自動的に生成される SafeGuard Enterprise 鍵 (グループ鍵など) とローカルで生成される鍵の違いに注意してください。
自動的に生成される鍵を選択する場合、鍵リングにこの鍵が含まれる任意のユーザがアーカイブを開くことができます。
ローカルで生成される鍵を選択する場合、この鍵のパスフレーズを入力することによって実行可能な受信者がアーカイブを開くことができます。
どちらの場合も、受信者は SafeGuard PrivateCrypto Version 2.30 以上のバージョンを使用している必要があります。
2.
SafeGuard PrivateCrypto を開きます。
ファイル リストにすべてのファイルをドラッグして追加します (Windows エクスプローラから SafeGuard PrivateCrypto のファイル リストにドラッグします)。 ディレクトリをドラッグする場合、ディレクトリ全体が追加され、ディレクトリ構造も保存されます。
パスワードを入力するか、鍵を選択し、確認してから、[OK] をクリックします。 アーカイブが指定したターゲット ディレクトリに作成されます。
デフォルト設定値 (ターゲット ディレクトリ、オプションなど) は SafeGuard PrivateCrypto User Application の [オプション] ダイアログで設定できます。
3.
Windows エクスプローラでファイルまたはディレクトリを選択します。
選択した内容を右クリックし、[SafeGuard PrivateCrypto] ショートカット メニューの [暗号化] をクリックします。
パスワードを入力するか、鍵を選択し、確認してから、[OK] をクリックします。 アーカイブが [暗号化されたアーカイブのターゲット] の下に指定された通りに作成されます。
デフォルト設定値 (ターゲット ディレクトリ、オプションなど) は SafeGuard PrivateCrypto User Application の [オプション] ダイアログで設定できます。


[暗号化ファイルを保存]

新規のアーカイブを保存するには、次の手順を実行します。
1.
SafeGuard PrivateCrypto User Application の [保存] アイコンをクリックします。 [暗号化ファイルを保存] ダイアログが表示されます。
2.
ここで、パスワードを入力するか、SafeGuard Enterprise 鍵を選択できます。
[パスワード]:
パスワードを入力し、確認してから、[OK] をクリックします。 アーカイブが指定したターゲット ディレクトリに作成されます。
デフォルト設定値 (ターゲット ディレクトリ、オプションなど) は SafeGuard PrivateCrypto User Application の [オプション] ダイアログで設定できます。
[鍵]:
ユーザの SafeGuard Enterprise 鍵リングから任意の鍵を選択できます。
自動的に生成される SafeGuard Enterprise 鍵 (グループ鍵など) とローカルで生成される鍵の違いに注意してください。
自動的に生成される鍵を選択する場合、鍵リングにこの鍵が含まれる任意のユーザがアーカイブを開くことができます。
ローカルで生成される鍵を選択する場合、この鍵のパスフレーズを入力することによって実行可能な受信者がアーカイブを開くことができます。
どちらの場合も、受信者は SafeGuard PrivateCrypto Version 2.30 以上のバージョンを使用している必要があります。
3.
デフォルトのターゲット ディレクトリ ([オプション] ダイアログで指定) が [ターゲット] フィールドに表示されます。
必要な場合、変更します。 新規のターゲット ディレクトリは、この 1 回の操作でのみ有効です。
4.
ファイル リストの最初のファイル名は、アーカイブの名前としてデフォルトによって提案されます。 ファイルの拡張子である .uti は、自動的に追加されます。
ファイル名は変更できます。

ヒント:
ファイルの拡張子を変更しないでください。

5.
[OK] をクリックします。
アーカイブを保存するには、SafeGuard PrivateCrypto User Application の [ファイル] メニューから [暗号 化ファイルを保存] および [暗号化ファイルに名前を付けて保存] コマンドも使用できます。


既存のアーカイブを開く

既存のアーカイブを開くには、単純に Windows エクスプローラでアーカイブをダブルクリックしま す。 SafeGuard PrivateCrypto User Application が自動的に起動します。
  • パスワード履歴の記録が有効になり、ファイルの安全性がパスワードで確保されたら、まずパスワード履歴ファイルのパスワードを入力するように求められます。 その後、アーカイブのパスワードを入力すると、アーカイブの内容が表示されます。
  • パスワード履歴の記録が有効になり、ファイルの安全性がユーザの鍵リングに含まれている SafeGuard Enterprise 鍵で確保されたら、アーカイブが自動的に開きます。
別のアーカイブを開くには、SafeGuard PrivateCrypto User Application の [ファイル] メニューから [開く] コマンドを使用します。
既存のアーカイブを開くには、Windows エクスプローラの [SafeGuard PrivateCrypto] ショートカット メ ニューから [復号化] コマンドを使用することもできます。 この場合、すぐにアーカイブが復号化され ます。 選択した暗号化タイプ (パスワードまたは SafeGuard Enterprise 鍵リングの鍵) に応じて、パス ワードを入力するか、使用した鍵が利用できる状態になっている必要があります。


アーカイブへのファイルの追加

既存のアーカイブにファイルを追加するには、[+] ボタンを使用します。 ボタンをクリックすると、[ファ イルの追加] ダイアログが開きます。このダイアログで追加するファイルを選択できます。
アーカイブにファイルおよびディレクトリを追加するには、SafeGuard PrivateCrypto User Application の [編集] メニューから [追加] および [ディレクトリの追加] コマンドを使用することもできます。
また、Windows エクスプローラから SafeGuard PrivateCrypto にファイルまたはディレクトリをドラッグ できます。
新しく追加されたファイルには、ファイル リストで緑の + 記号が付けられます。 SafeGuard PrivateCrypto User Application の [保存] 記号をクリックした後、これらのファイルが暗号化されたアー カイブに追加されます。


アーカイブからのファイルの削除

既存のアーカイブからファイルを削除するには、[-] ボタンを使用します。 削除するファイルを PrivateCrypto メイン ウィンドウで選択し、[-] ボタンをクリックします。 初期段階では、ファイルには 赤の [-] が付きます。 そして、SafeGuard PrivateCrypto User Application の [保存] アイコンをクリックし た後、削除されます。
アーカイブからファイルを削除するには、SafeGuard PrivateCrypto User Application の [編集] メニュー から [削除] コマンドを使用することも、キーボードの Remove キーを使用することもできます。


ファイルおよびアーカイブの復号化

ファイルおよびアーカイブを復号化するには、次の手順を実行します。
1.
SafeGuard PrivateCrypto User Application のファイル リストから必要なファイル (複数可) を選択し
ます。
2.
ツールバーの [復号化] アイコンをクリックします。
[復号化] ダイアログが表示されます。
3.
必要な場合、ターゲット ディレクトリを変更するか、[全てのファイルの復号化後、アーカイブを安全に削除] オプションを選択します。あるいはその両方を実行します。
4.
[OK] をクリックします。
選択したすべてのファイルが復号化され、ターゲット ディレクトリに保存されます。

ヒント:
アーカイブ全体を復号化するには、Windows エクスプローラを選択し、[SafeGuard PrivateCrypto] ショートカット メニューの [復号化] をクリックします。 入力する必要があるのは、パスワードだけ です。 暗号化に SafeGuard Enterprise 鍵を使用した場合、使用した鍵が利用できる状態の場合に限り、 アーカイブが自動的に復号化されます。 この方法では、個別ファイルを復号化することはできません。


SafeGuard PrivateCrypto Explorer の拡張機能

SafeGuard PrivateCrypto Explorer の拡張機能は、ファイルおよびディレクトリを暗号化する簡単な方法 を提供しています。 さらに、ユーザはこれらの機能によってファイル/ディレクトリを暗号化し、 Windows エクスプローラから直接送信できます。
ファイル/ディレクトリを右クリックすると、次のコマンドが [SafeGuard PrivateCrypto] サブメニュー に含まれた状態でショートカット メニューが表示されます。
  • [暗号化]
    Windows エクスプローラで直接ファイル/ディレクトリを暗号化します。
  • [PrivateCypto]
    SafeGuard PrivateCrypto User Application を起動します。 選択したファイル/ディレクトリがユーザ アプリケーションのリスト ビューに表示されます。 そのため、ユーザは選択肢に対して特定のファイルの追加または削除を実行できます。
  • [暗号化と送信]
ファイル/ディレクトリを暗号化した後に、それらをすぐに電子メール クライアントを介して送信します。
暗号化が成功すると、電子メール クライアントが起動し、暗号化されたアーカイブが自動的に添付されます。

ヒント:
SafeGuard PrivateCrypto による電子メールを介したアーカイブの送信のサポートには、システムに適 切に設定された電子メール プログラムが必要になります。

  • SafeGuard PrivateCrypto は、MAPI (Mail Application Program Interface) と呼ばれる Windows 機能を使用して、電子メール プログラムと通信します。 この標準インターフェイスによって、SafeGuard PrivateCrypto および他のアプリケーションが電子メール プログラムを制御できます (たとえば、メッセージの作成またはファイルの添付)。正常な機能を保証するためには、システムで次の条件が満たされている必要があります。
    • 電子メール プログラムが MAPI 対応メール システムである必要があります。
    • 電子メール プログラムが SafeGuard PrivateCrypto で必要な "Simple MAPI" インターフェイスをサポートしている必要があります。
    • 電子メール プログラムは、標準メール クライアント (または "プライマリ MAPI クライアント") として設定されています。
  • [安全な削除]
    今後復元されないように、ファイルを安全に削除します。


ファイルの暗号化

SafeGuard PrivateCrypto を使用してファイルを暗号化する場合、次の手順を実行します。
1.
Windows エクスプローラでファイルを選択します。
2.
選択したファイルを右クリックします。
[SafeGuard PrivateCrypto] エントリが含まれたショートカット メニューが表示されます。
3.
[暗号化] をクリックします。
[SafeGuard PrivateCrypto - 暗号化ファイルを保存] ダイアログが表示されます。
4.
ここで、パスワードを入力するか、SafeGuard Enterprise 鍵を選択できます。
[パスワード]:
[パスワード] フィールドにパスワード (最大 32 の文字または数字) を入力し、[確認] フィールドで内容を確認します。
[鍵]:
ユーザの SafeGuard Enterprise 鍵リングから任意の鍵を選択できます。
自動的に生成される SafeGuard Enterprise 鍵 (グループ鍵など) とローカルで生成される鍵の違いに注意してください。
自動的に生成される鍵を選択する場合、鍵リングにこの鍵が含まれる任意のユーザがアーカイブを開くことができます。
ローカルで生成される鍵を選択する場合、この鍵のパスフレーズを入力することによって実行可能な受信者がアーカイブを開くことができます。
どちらの場合も、受信者は SafeGuard PrivateCrypto Version 2.30 以上のバージョンを使用している必要があります。
5.
自己解凍実行可能プログラムを作成する場合、[自己解凍実行可能ファイルの作成] オプションを有効にします。
[ターゲット]
[ターゲット] フィールドには、SafeGuard PrivateCrypto User Application の [オプション] ダイアログに指定された暗号化されたアーカイブのデフォルト ターゲットが表示されます。 アーカイブの最初のファイル名は、暗号化されたファイル/アーカイブの名前として提案されます。デフォルトによってファイルの拡張子である .uti が SafeGuard PrivateCrypto の暗号化されたファイルに追加されます。 ファイル名の拡張子を変更すると、ファイルが使用できなくなる場合があります。
フィールドの横にある [...] ボタンを使用して、暗号化されたソース ファイルが保存されている別のフォルダを指定できます (編集フィールドに直接、新規のパスを入力することもできます)。
[オプション] ボタンをクリックすると、SafeGuard PrivateCrypto はさらに次のオプションを提供します。
[暗号化後にソース ファイルを安全に削除]:
このオプションが有効な場合、ソース ファイルが消去され、今後復元できなくなります。 ファイルの暗号化されたバージョンだけがシステムに残ります。
[データの圧縮]:
選択したファイル/アーカイブを圧縮します。 非常に小さなファイルまたはすでに圧縮されたファイルで使用した場合、圧縮によってファイルのサイズが増加する可能性があることに留意してください。 圧縮が有効にされている場合、アーカイブの作成にかなり時間がかかります。
[パスワード履歴にパスワードを記録]:
パスワードがパスワード履歴に保存されます。

ヒント:
これらのオプションは、SafeGuard PrivateCrypto User Application の [オプション] ダイアログに事前 に定義されています。 このダイアログへの変更は、この 1 回の暗号化操作に対してのみデフォルト設 定値を上書きします。

6.
[OK] をクリックします。


ファイルの復号化

SafeGuard PrivateCrypto を使用してファイルを復号化するには、次の手順を実行します。
1.
Windows エクスプローラでファイルを選択します。
2.
選択したアーカイブを右クリックします。
[SafeGuard PrivateCrypto] エントリが含まれたショートカット メニューが表示されます。
3.
[復号化] をクリックします。
[復号化] ダイアログが表示されます。
  • パスワードでアーカイブが暗号化された場合、パスワードを入力するように求められます。 [OK] をクリックすると、アーカイブが復号化されます。

    • ヒント:
    間違ったパスワードが入力されると、そのたびに待機時間が延長されます。

[オプション] ボタンをクリックすると、SafeGuard PrivateCrypto はさらに次のオプションを提供します。
[ターゲット]
[ターゲット] フィールドには、SafeGuard PrivateCrypto User Application [オプション] ダイアログに指定された復号化されたアーカイブのデフォルト ターゲットが表示されます。 フィールドの横にある [...] ボタンを使用して、暗号化されたソース ファイルが保存されている別のフォルダを指定できます (編集フィールドに直接、新規のパスを入力することもできます)。
[全てのファイルの復号化後、アーカイブを安全に削除]
このオプションが有効な場合、暗号化されたアーカイブが消去され、今後復元できなくなります。 ファイルの復号化されたバージョンだけがシステムに残ります。

ヒント:
これらのオプションは、SafeGuard PrivateCrypto User Application の [オプション] ダイアログに事前 に定義されています。 このダイアログへの変更は、この 1 回の復号化操作に対してのみデフォルト設 定値を上書きします。

  • ユーザの鍵リングに含まれている SafeGuard Enterprise 鍵でアーカイブを暗号化した場合、アーカイブは自動的に復号化されます。


自己解凍実行可能ファイルの作成

SafeGuard PrivateCrypto では、自己解凍実行可能ファイルを作成することができます。 自己解凍実行可 能ファイルの利点は、SafeGuard PrivateCrypto をインストールしていないユーザでも復号化できること です。 復号化に必要なのは、ローカルで生成された SafeGuard Enterprise 鍵のパスワードまたはパスフ レーズだけです。
SafeGuard PrivateCrypto では、ローカルで作成された SafeGuard Enterprise 鍵を使用して、自己解凍型プ ログラムも作成できます。 これらの .exe ファイルは、SafeGuard PrivateCrypto も SafeGuard Enterprise も インストールされていないコンピュータでも復号化できます。 プログラムを起動する際に、ユーザは ローカル鍵のパスフレーズを入力するように求められます。 このパスフレーズは、事前に受信者に連 絡されている必要があります。
パスフレーズは、SafeGuard Enterprise のローカル鍵を作成するときに定義されます。
SafeGuard PrivateCrypto を使用して自己解凍実行可能ファイルを作成するには、次の手順を実行します。
1.
Windows エクスプローラでファイルを選択します。
2.
選択したファイルを右クリックします。
[SafeGuard PrivateCrypto] エントリが含まれたショートカット メニューが表示されます。
3.
[暗号化] をクリックします。
[SafeGuard PrivateCrypto - 暗号化ファイルを保存] ダイアログが表示されます。
4.
ここで、パスワードを入力するか、SafeGuard Enterprise 鍵を選択できます。
[パスワード]:
[パスワード]フィールドにパスワード (最大 32 の文字または数字) を入力し、[確認] フィールドで内容を確認します。
[鍵]:
自己解凍型プログラムの場合、ローカルで作成した SafeGuard Enterprise 鍵を使用できます。 ファイルを復号化するには、受信者はこの鍵のパスフレーズを入力する必要があります。 パスフレーズは、SafeGuard Enterprise のローカル鍵を作成するときに定義されます。
5.
[自己解凍実行可能ファイルの作成] オプションを有効にします。
[ターゲット]
[ターゲット] フィールドには、SafeGuard PrivateCrypto User Application の [オプション] ダイアログに指定された暗号化されたアーカイブのデフォルト ターゲットが表示されます。 アーカイブの最初のファイル名は、暗号化されたファイル/アーカイブの名前として提案されます。 デフォルトでは、ファイルの拡張子である .uti がSafeGuard PrivateCrypto の暗号化されたファイルに追加されます。 ファイル名の拡張子を変更すると、ファイルが使用できなくなる場合があります。
編集フィールドの横にある [...] ボタンを使用して、暗号化されたソース ファイルが保存されている別のフォルダを指定できます (編集フィールドに直接、新規のパスを入力することもできます)。
[オプション] ボタンをクリックすると、SafeGuard PrivateCrypto はさらに次のオプションを提供します。
[暗号化後にソース ファイルを安全に削除]:
このオプションが有効な場合、ソース ファイルが消去され、今後復元できなくなります。 ファイルの暗号化されたバージョンだけがシステムに残ります。
[データの圧縮]:
選択したファイル/アーカイブを圧縮します。
非常に小さなファイルまたはすでに圧縮されたファイルで使用した場合、圧縮によってファイルのサイズが増加する可能性があることに留意してください。またデータを圧縮する場合は、アーカイブ作成時の処理時間が長くなることがあります。
[パスワード履歴にパスワードを記録]:
パスワードがパスワード履歴に保存されます。
6.
[OK] をクリックします。


パスワードの最小長

SafeGuard PrivateCrypto では、パスワードの最小長を定義できます。 そのため、以下の鍵の下の DWORD エントリ PasswordLengthMin を
HKEY_LOCAL_MACHINE\SOFTWARE\UTIMACO\SGPC
Windows レジストリに追加する必要があります。 パスワードの最小長を文字で定義する PasswordLengthMin の値を定義します。


SafeGuard PrivateCrypto コマンド ライン インターフェイス

SafeGuard PrivateCrypto のコマンド ライン構文は、次のとおりです (SafeGuard PrivateCrypto のインス トール ディレクトリから pcrypt を呼び出します)。
pcrypt [ソース ファイルのパスと名前] [オプション]
オプション:

-e<アーカイブ> | 所定の暗号化アーカイブを作成します。 所定のアーカイブがない場合、拡張子 が .uti に変更された状態で最初のファイル名が使用されます。
-d<アーカイブ> | 所定の暗号化アーカイブを復号化します。
-a<アーカイブ> | 所定のファイルを既存のアーカイブに追加します。 ターゲット アーカイブが存 在しない場合、作成されます。
-x<アーカイブ> | 自己解凍実行可能ファイルを作成します。
-o<ディレクトリ> | 出力ディレクトリ (復号化用)
-p<パスワード> | 暗号化/復号化のパスワード
-l<パスワード> | ログ ファイルのパスワード
-m | 暗号化の後、アーカイブを送信します。
-n | ユーザ インターフェイスを非表示にしますが、エラー メッセージは表示します。
-q | ユーザ インターフェイスとエラー メッセージを非表示にします。
-c[+|-] | 暗号化のときにデータを圧縮します。
-s[+|-] | 暗号化/復号化の後、ソース ファイルを削除します。
-t[+|-] | 既存のターゲット ファイルを上書きします。
-h | コマンド ライン構文を表示します。
-w | ファイルを消去します。 暗号化および復号化と組み合わせることはできません。
-aes256 | AES-256 暗号化アルゴリズムを使用します。 これは、新規のアーカイブにのみ 適用されます。 SafeGuardPrivateCrypto オプションに事前に定義された値がデ フォルトになります。
@<ファイル> | "@" で開始するファイル名は、追加のファイル名とオプションが含まれる可能 性がある制御ファイルとして解釈されます。 これにより、コマンド ラインのサ イズ制限によって通常は許可されない大きいコマンド ラインの文字列を渡すこ とができます。

例:
pcrypt utimaco.txt -e -oC:\Encrypted\Utimaco_Enc.txt -p12345678 -n -s
utimaco.txt ファイルは暗号化され、C:\Encrypted ディレクトリに Utimaco_Enc.txt.uti と して保存されます(ファイルの拡張子である .uti が自動的に追加されます)。 ファイルを復号化する パスワードは 12345678 です。-n が指定されているので、ユーザ インターフェイスは表示されません
(たとえば、パスワードの入力に対して)。 pcrypt が呼び出されたのと同じディレクトリにあるソース ファイルは、暗号化の後で削除されます (-s)。
2 つのファイルでアーカイブを作成する場合:
Pcrypt test.txt test2.txt -etest.uti -psecret
3 つ目のファイルおよびファイルが含まれているディレクトリを (再帰的に) 上記のアーカイブに追加 する場合:
Pcrypt test3.txt c:\winnt -atest.uti -psecret
アーカイブからいくつかのファイルを抽出する場合:
Pcrypt -dtest.uti test.txt test2.txt -psecret


SafeGuard PrivateCrypto OLE オートメーション インターフェイス

SafeGuard PrivateCrypto には、Windows スクリプトに対応しているすべてのアプリケーション内の PrivateCrypto のプログラムに使用可能な OLE オートメーション サーバがあります。 Windows スクリプ ト対応アプリケーションには、Windows Scripting Host (Visual Basic Scripting、JavaScript、Perl などをサ ポート) や、Microsoft Office アプリケーション、Web ページ、Visual Basic や Visual C++ などのプログ ラミング環境などがあります。
エクスポートされるクラスには、"PrivateCrypto.Archive" の名前が付きます。 スクリプトの互換性を保 つため、次のコマンドとプロパティによる IDispatch インターフェイスがエクスポートされます。
プロパティ:
PrivateCrypto.Archive オブジェクトのプロパティは、PrivateCrypto オプションの定義の通りに事前に設 定されています。 アーカイブ オブジェクトのプロパティの変更は、この単一オブジェクトの後続の操 作にのみ影響し、グローバル設定値は変更されません。
CompressData | ブーリ アン | 圧縮 (オン/オフ)
DecryptDeleteSource | ブーリ アン | すべてのファイルを抽出した後に、暗号化アーカイブを安全に削 除 (消去) します。 これは、アーカイブのすべてのファイルが正常に抽出された場合 にのみ実行されます。 単一ファイルを抽出する場合、アーカイブにある唯一のファイル である場合であっても、アーカイブ全体は削除されません。
DecryptFolder | 文字列 | 復号化されたアーカイブのターゲット フォルダ
EncryptDeleteSource | ブーリ アン | ソース ファイルが暗号化アーカイブに正常に追加された後、こ れらのファイルを安全に削除 (消去) します。
EncryptFolder | 文字列 | 暗号化アーカイブのターゲット フォルダ
EncryptAlgorithm | 整数 | アーカイブの暗号化アルゴリズム。 SafeGuardPrivateCrypto オプ ションに事前に定義された値がデフォルトになります。 サポートされている値は、 2=AES-256 です。
NoGui | ブーリ アン | GUI をまったく表示させない場合、このオプションを True に設 定できます。 この場合、ダイアログもメッセージ ボックスも表示 されません。 このオプションはデフォルトごとに False に設定されています。 その結果、コマンド パラメータとしてすでにパスワードが渡さ れていないかを確認するメッセージが表示され、エラーの場合は 説明文が書かれたメッセージ ボックスが表示されます。 "NoGui" プロパティが True に設定されていても、ユーザの介在 が必要な場合 (たとえば、パスワードの入力)、現在の操作がす べてキャセルされ、該当するエラー コードが返されます。
PasswordLogEnabled | ブーリ アン | 新規の暗号化アーカイブを作成する場合のパスワード ログ ファ イルのログ パスワード
コマンド:
次は、PrivateCrypto.Archive オブジェクトで呼び出すことができるコマンドのリストです。 括弧内のパ ラメータは、オプションです。 単一パラメータの説明については、コマンドの下の表を参照してくだ さい。
AddFiles archive, files, pwd, (logpwd), (comment) | 1 つまたは複数のファイルを暗号化アーカイブに追加します。 アーカイブが存在しない場合は、作成されます。
CreateSFX archive, files, (pwd), (logpwd), (comment) | 1 つまたは複数のファイルを含む自己解凍実行可能ファイル を作成します。
Decrypt archive, (files), (pwd) | 1 つ、複数、またはすべてのファイルを暗号化アーカイブか ら抽出します。 ここでは、ファイル パラメータは省略するこ とができます。 この場合、すべてのファイルがアーカイブか ら抽出されます。
Encrypt archive, files, (pwd), (logpwd), (comment) | 1 つまたは複数のファイルを含む新規の暗号化アーカイブを 作成します。 ターゲット ファイルがすでに存在する場合、上 書きするかどうかのメッセージが表示されます。
RemoveFiles archive, files, (pwd) | 暗号化アーカイブから 1 つまたは複数のファイルを削除しま す。 ファイルは復号化されず、アーカイブから削除されるだ けです。 パスワードは、認証の目的でのみ使用されます。
パラメータ:
archive | 暗号化アーカイブの名前。 これは、すべてのコマンドで必要になります。
files | これは、単一のファイル名であるか、ファイル名の配列であるかを指定します。 ファ イル名の配列方法については、以下の例を参照してください。
pwd | 暗号化アーカイブのパスワード。 新規のアーカイブが作成され、パスワードの記録が 有効になっている場合、パスワードがログ ファイルに書き込まれます。 このパラメー タは、すべてのコマンドで空の状態にすることができます。 この場合、ユーザはパス ワードを求められます。
logpwd | パスワード履歴ファイルのパスワード。 パスワード ログ ファイルにエントリを追加す る必要がある場合、ログ ファイルのアクセスにこのパスワードが使用されます。 パス ワードがすでにレジストリに存在する場合、パスワードは不要です。
comment | パスワード履歴エントリのコメント


スクリプトの例

次に、サポートされているすべての OLE オートメーション関数の使用法について説明する VBScript コードの一部の例を示します。
language = "VBScript"
'======================================================
'
' This script demonstrates the SafeGuard® PrivateCrypto OLE automation object.
' During the demo, files are created in the "c:\demo" directory.
'
'======================================================
On Error Resume Next
'
' Define the name of the directory used by this demo.
' This will automatically be created, if necessary.
'
sFolder = "c:\demo"
'
' Create the necessary files for this demo
'
Call Install(sFolder)
'
' Declare and create our object for interfacing SafeGuard® PrivateCrypto
'
Dim pc
Set pc = CreateObject ("PrivateCrypto.Archive")
'
' Set encryption options
'
pc.CompressData = True
pc.EncryptDeleteSource = False
'
' Create an encryption archive, holding all files from the "files" subdirectory
'
If Not pc.Encrypt(sFolder & "\test.uti", sFolder & "\files", "secret") then
MsgBox pc.GetErrorText
End If
'
' Create a self-extracting executable from a given
' list of files. Note that if one of the given file names
' represents a directory, all files within this directory
' are used. Further, the optional log file password parameter
' is filled out here.
'
Dim arrayCreate(2)
arrayCreate(0) = sFolder & "\files"
arrayCreate(1) = sFolder & "\test.uti"
If Not pc.CreateSFX(sFolder & "\test.exe", arrayCreate, "secret", "logpwd") then
MsgBox pc.GetErrorText
End If
'
' Decrypt all files from an archive to a given location.
' Note that the empty files array parameter (par #2) specifies
' to extract all files.
'
pc.DecryptFolder = sFolder & "\decrypt"
If Not pc.Decrypt(sFolder & "\test.uti", ,"secret") then
MsgBox pc.GetErrorText
End If
'
' Remove a list of files from an archive
'
Dim arrayRemove(2)
arrayRemove(0) = "files\test2.txt"
arrayRemove(1) = "files\test3.txt"
If Not pc.RemoveFiles(sFolder & "\test.uti", arrayRemove, "secret") then
MsgBox pc.GetErrorText
End If
'
' Add a single file to an encryption archive
'
If Not pc.AddFiles(sFolder & "\test.uti", sFolder & "\files\test2.txt", "secret") then
MsgBox pc.GetErrorText
End If
'
' Free the SafeGuard® PrivateCrypto automation object
'
Set pc = nothing
MsgBox "End of demo. Generated files can be found in folder " & sFolder & "."
'
'------------------------------------------------------
' Helper routine to set-up files used by the demo script
'------------------------------------------------------
'
Sub Install (sFolder)
On Error Resume Next
Dim fso
Dim file
'
' Create a filesystem-object
'
Set fso = CreateObject("Scripting.FileSystemObject")
'
' Create directories used by the demo
'
fso.CreateFolder sFolder
fso.CreateFolder sFolder & "\files"
'
' Delete old files from earlier runs of this demo
'
fso.DeleteFile sFolder & "\test.uti"
fso.DeleteFile sFolder & "\test.exe"
fso.DeleteFile sFolder & "\decrypt\*.*"
fso.DeleteFile sFolder & "\decrypt\files\*.*"
'
' Create input files for the demo
'
    Set file = fso.CreateTextFile(sFolder & "\files\
    test1.txt", True)
file.WriteLine("This is a demo text file.")
file.Close
fso.CopyFile sFolder & "\files\test1.txt", sFolder &
    "\files\test2.txt"
fso.CopyFile sFolder & "\files\test1.txt", sFolder &
    "\files\test3.txt"
Set fso = nothing
End Sub


End User License Agreement

TERMS AND CONDITIONS
(Status: October 15, 2007)
If you continue with the download/installation, you expressly declare your consent to the following terms and conditions:

Part 1 - General Terms

1. Subject of this Agreement

The subject of this Agreement is the program, program description, operating instructions and additional accompanying material and/or documentation provided by Utimaco according to this Agreement, including any software owned by Utimaco's licensors and licensed to Utimaco for distribution as part of the Utimaco offering (collectively, the "Software"). Utimaco Safeware AG ("Utimaco") notes that it is not possible given the current state of the art to create computer software so that it will work without any errors in all applications and hardware combinations. The subject of this Agreement is therefore only software that can generally be used in the manner set out in the program description, and the operating instructions and other documentation accompanying such software. You acknowledge and agree that reference to Utimaco's licensors relating to the Software shall not be deemed to establish any contractual relationship between you and such licensors with respect to your rights under this Agreement, and you shall look solely to Utimaco and/or its resellers and distributors to enforce any such rights under this Agreement.

2. Scope of Usage; Download / Installation of Software

2.1 Upon your acceptance of these Terms and Conditions and subject to payment of the Licence Fee (as set forth in Section 7) , you will have a non-exclusive, non-transferable, non-assignable right to use the Software on the number of computer machines or network server indicated on order confirmations, delivery notes and / or invoices for the term of this Agreement. Any use going beyond these terms is expressly prohibited. This license does not constitute a sale of the Software or any portion or copy of it.

2.2 Upon your acceptance of these Terms and Conditions, you may download and install the Software and documentation. The Software shall be deemed accepted upon such download. If any feature or module of the Software is found not to conform with the express warranties set forth herein, you shall, within the warranty period, as set forth in Section 8 hereof, notify Utimaco and provide a detailed description of such defects. Your sole remedy for correction of problems after acceptance shall be pursuant to the provisions of Section 8 hereof.

3. Special Restrictions; Updates

The foregoing license rights are subject to the following restrictions:

3.1 You agree that all future modifications, enhancements, updates, revisions and/or new releases to the Software created by Utimaco (or its licensors, as applicable) shall be the sole property of Utimaco (or its licensors, as applicable).

3.2 You may make a reasonable number of copies of the Software, solely for archival and back-up purposes, provided that all of Utimaco's (or its licensors') copyright notices or other proprietary or restrictive legends or notices are reproduced on all such copies.

3.3 You shall retain the Software in strict confidence and not disclose to any third party (except as authorized by this Agreement), without Utimaco's express written consent. Utimaco hereby consents to the disclosure of the Software to your employees and contractors provided that such employee or contractor has a need to know such proprietary information.

3.4 Except for the license rights expressly and unambiguously set forth herein, you acknowledge that Utimaco or, as applicable, its licensors, retain all right, title and interest in and to the original, and any copies, of the Software and documentation, whether in machine-readable or printed form (and including, without limitation, derivative works, compilations, or collective works thereof and all related technical know-how and all rights therein), and that ownership of all patent, copyright, trademark, tradename, trade secret, technology, ideas, know-how, and other intellectual property rights pertaining thereto, shall be and remain the sole property of Utimaco or, as applicable, its licensors. You shall not be an owner of any copies of, or have any interest in, the Software, but rather, such Software is licensed pursuant to this Agreement to install and use such copies. Except for the rights expressly and unambiguously granted hereunder, Utimaco reserves for itself and its licensors all other rights in and to the Software and documentation. You shall not take any action to jeopardize, limit or interfere in any manner with Utimaco's or, as applicable, its licensors', ownership of or rights with respect to the Software and documentation.

3.5 You shall be responsible for (i) the selection, efficiency and suitability of the Software for your business purposes; (ii) the use of the Software in accordance with the documentation furnished by Utimaco; (iii) any claim of infringement based upon your combination of the Software with data or other software or devices not furnished or approved in writing by Utimaco; or (iv) the installation of the Software.

3.6 Except as expressly provided herein or to the extent permitted under applicable law, you shall not, (i) directly or indirectly, copy, modify, translate, reverse compile, disassemble, reverse engineer or otherwise determine or attempt to determine the source code of the Software or to create any derivative works based on the Software or documentation, (ii) create any modifications, enhancements, updates, revisions and / or new releases of the Software.

3.7 You shall promptly notify Utimaco in writing of any actual or suspected breach of any material obligation under this Agreement which comes to your attention, and shall cooperate with Utimaco in any legal action to prevent or stop unauthorized use, reproduction or distribution of Software or documentation.

4. Transfer of Usage Rights

You shall have no right to sell, sublicense, convey, transfer, assign, make available for time-sharing or service bureau purposes or otherwise dispose of its rights or obligations hereunder, by operation of law or otherwise to any third party, without the prior written consent of Utimaco.

5. Reproduction of Copyright Notice

The Software and the accompanying written materials are protected by copyright. A copyright note contained in the Software and a registration number contained therein may not be removed.

6. Term of this Agreement

This Agreement shall have an indefinite term unless terminated earlier as provided herein. Either party may terminate this Agreement by written notice if the other party (i) commits a material or persistent breach of this Agreement, which breach, if capable of being cured, is not cured within thirty (30) days of a written notice of termination, or (ii) becomes insolvent, makes a general assignment for the benefit of creditors, files a voluntary petition of bankruptcy, suffers or permits the appointment of a receiver for its business or assets, or becomes subject to any proceedings under any bankruptcy or insolvency law, whether domestic or foreign, or has wound up or liquidated, voluntarily or otherwise. In the event your license is terminated (i) you shall erase or return to Utimaco the Software, including all copies of the Software including any portions that have been changed and the documentation (ii) and all rights granted for you under this Agreement will cease automatically. All disclaimers, limitations of liability, indemnities and other restrictions contained in this Agreement shall survive any termination of the license granted herein.

7. License Fees

7.1 In consideration of the rights and licenses granted to Software hereunder You shall pay to Utimaco upon delivery / installation of Software license fees as separately agreed between the parties in writing (the "License Fees") as well as applicable local, state or federal taxes.

7.2 The License Fees as well as applicable taxes shall be invoiced by Utimaco to You and paid by You in accordance with the invoice by money transfer to Utimaco`s bank account with the payment term of thirty (30) days net. The interest of delay of due payment under this Agreement shall be fixed at ten percent (10%) per annum.

8. Limited Warranty

8.1 Utimaco warrants only to you that the Software, if properly installed and used by you, will function substantially in accordance with material specifications in the technical and user documentation in effect at the time of download to you; provided however, that Utimaco does not warrant that the operation of the Software will be, or that the documentation is or will be, error or bug free or uninterrupted, and Utimaco disclaims any and all liability on account thereof. Utimaco shall have no liability for any claim under this Section 8 not received by Utimaco within sixty (60) days after you download the Software.

Utimaco's sole and exclusive liability, and your sole and exclusive remedy, shall be, at Utimaco's sole election, to provide program services to attempt, through reasonable efforts, to either repair or replace such nonconforming element; provided however, that if repair or replacement is impracticable and you have been damaged by such nonconformance, then Utimaco shall refund the fees paid by you which are allocable to such nonconforming element.

The above remedies are available only if Utimaco is promptly notified in writing, within the warranty period, upon discovery of the nonconformities by you and Utimaco's examination of the Software discloses that such nonconformities exist.

Utimaco shall have no obligation under the foregoing warranty for any nonconformance caused by: (i) the incorporation, attachment or engagement of any attachment, feature, program or device, other than by Utimaco, to the Software or any part thereof; (ii) accident, transportation, neglect or misuse; (iii) alteration, modification, or enhancement of the Software other than by Utimaco; (iv) use of the Software for other than the intended purpose; (v) use of the Software on any systems other than the specified hardware platform for such Software; (vi) your use of defective media or defective duplication of the Software; or (vii) your failure to incorporate any Update previously furnished by Utimaco which corrects such nonconformance. ANY REFUND OF FEES SHALL BE DEEMED A TERMINATION OF THIS AGREEMENT (AND ANY RELATED MAINTENANCE AGREEMENT) AND SHALL BE YOUR SOLE AND EXCLUSIVE REMEDY FOR BREACH OF THE FOREGOING WARRANTY OR REJECTION OF THE SOFTWARE, AND NEITHER PARTY SHALL HAVE ANY FUTURE OBLIGATIONS OR LIABILITY HEREUNDER WITH RESPECT TO SUCH SOFTWARE.

8.2 EXCEPT FOR THE EXPRESS LIMITED WARRANTIES SET FORTH IN THIS SECTION 8, NEITHER UTIMACO NOR ANY OF ITS DISTRIBUTORS OR RESELLERS MAKE ANY WARRANTIES EXPRESS, IMPLIED (EITHER IN FACT OR BY OPERATION OF LAW), STATUTORY OR IN ANY COMMUNICATION WITH YOU WITH RESPECT TO THE SOFTWARE, OR ANY SERVICES PROVIDED IN CONNECTION THEREWITH, AND UTIMACO EXPRESSLY DISCLAIMS ANY IMPLIED WARRANTIES OR CONDITIONS INCLUDING THOSE OF TITLE, MERCHANTABILITY, NON-INFRINGEMENT AND FITNESS FOR A PARTICULAR PURPOSE.

8.3 You acknowledge that as between you and Utimaco, you are solely responsible for your relationship with third party resellers of the Software. Accordingly, you hereby waive any claim or cause of action against or through such resellers involving or in connection with Utimaco or the Software. All such claims shall be deemed excluded under Section 10.

8.4 You further acknowledge and agree that you shall be solely responsible for proper back-up of all data stored in the Software and that you shall take measures to ensure such. Utimaco assumes no liability or responsibility whatsoever if data is lost.

9. Indemnification

9.1 Provided that you have used the Software in accordance with this Agreement Utimaco agrees to defend or, at its option, to settle, any claim brought against you by a third party for infringement of any third party intellectual property rights by the Software as used within the scope of this Agreement, and to indemnify you against all damages and costs finally awarded against you under any such claim or action. You agree that Utimaco shall be released from the foregoing obligation unless you have taken all reasonable steps to mitigate any potential expenses and you provide Utimaco with (a) prompt written notice of any such claim or action, or possibility thereof; (b) sole control and authority over the defense or settlement of such claim or action; and (c) proper and full information and assistance to settle and/or defend any such claim or action. If Utimaco, in its sole discretion, believes that an injunction is likely to be filed prohibiting the use of the Software by you, Utimaco may, at its sole option and expense, either: (i) procure for you the right to use the infringing Software as provided herein, (ii) replace the infringing Software with non-infringing equivalent software; (iii) modify the infringing Software so that it is not infringing; or (iv) demand return of the Software, refund the fees paid by you to Utimaco less any reasonable sum in respect of the use of the Software up to the date of termination and terminate this Agreement. Upon exercise of option (iv) in the previous sentence, Utimaco shall have no further obligations or liability to you. Except as specified above, Utimaco will not be liable for any costs or expenses incurred without its prior written authorization.

9.2 Notwithstanding the provisions of Section 9.1 above, Utimaco assumes no liability for (i) the combination of the Software with other products not provided by Utimaco; (ii) any modifications to the Software unless such modification was made by Utimaco; (iii) use of the Software if the infringement would have been avoided if the Software had been used in accordance with the documentation; (iv) any unauthorized use of Utimaco's intellectual property; or (v) third party software incorporated in the Software.

9.3 THE FOREGOING PROVISIONS OF THIS SECTION 9 STATE THE ENTIRE LIABILITY AND OBLIGATIONS OF UTIMACO, AND YOUR EXCLUSIVE REMEDY, WITH RESPECT TO ANY ACTUAL OR ALLEGED INFRINGEMENT OF ANY PATENT, COPYRIGHT, TRADE SECRET, TRADEMARK OR OTHER INTELLECTUAL PROPERTY RIGHT BY THE SOFTWARE OR ANY PART THEREOF.

9.4 You shall indemnify, hold harmless and, at Utimaco's request, defend Utimaco from and against any and all claims, liabilities, losses, damages, expenses, and costs (including attorneys' fees and costs) relating to infringement or misappropriation of intellectual property rights other than those stipulated in Section 9.1.

10. Limitation of Liability

10.1 EXCEPT FOR CLAIMS UNDER SECTION 9 RELATING TO INTELLECTUAL PROPERTY IN NO EVENT SHALL UTIMACO'S AGGREGATE LIABILITY TO YOU AND ANY THIRD PARTY ARISING OUT OF OR IN CONNECTION WITH THIS AGREEMENT, FROM ALL CAUSES OF ACTION AND THEORIES OF LIABILITY, EXCEED THE AMOUNTS PAID BY YOU FOR THE SOFTWARE.

10.2 EXCEPT FOR MISAPPROPRIATION OF UTIMACO'S (OR ITS LICENSORS') INTELLECTUAL PROPERTY BY YOU IN NO EVENT SHALL EITHER PARTY HAVE ANY LIABILITY TO THE OTHER PARTY OR TO ANY THIRD PARTY FOR ANY SPECIAL, PUNITIVE, INDIRECT, INCIDENTAL OR CONSEQUENTIAL DAMAGES INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOST PROFITS, LOSS OF DATA OR COSTS OF PROCUREMENT OF SUBSTITUTE GOODS, TECHNOLOGY OR SERVICES, ARISING OUT OF OR IN CONNECTION WITH THIS AGREEMENT OR THE USE OR PERFORMANCE OF THE SOFTWARE, WHETHER SUCH LIABILITY ARISES FROM ANY CLAIM BASED UPON CONTRACT, WARRANTY, TORT (INCLUDING NEGLIGENCE), PRODUCT LIABILITY OR OTHERWISE, EVEN IF ADVISED IN ADVANCE OF THE POSSIBILITY OF SUCH LOSS OR DAMAGES. THESE LIMITATIONS SHALL APPLY NOTWITHSTANDING THE FAILURE OF THE ESSENTIAL PURPOSE OF ANY LIMITED REMEDY. IN NO EVENT SHALL UTIMACO BE LIABLE FOR ANY REPRESENTATION OR WARRANTY MADE TO ANY THIRD PARTY BY YOU OR FOR ANY CLAIMS DIRECTLY OR INDIRECTLY RELATED TO ANY AND ALL FUTURE MODIFICATIONS, ENHANCEMENTS, UPDATES, REVISIONS AND/OR NEW RELEASES TO THE SOFTWARE CREATED BY YOU. THE PARTIES HEREBY EXPRESSLY ACKNOWLEDGE THAT THE LICENSE FEE REFLECTS THE ALLOCATION OF RISK SET FORTH IN THIS SECTION 10.

10.3 The invalidity, in whole or part, of any of the foregoing subsections will not affect the remainder of such section or subsection or any other section or subsection of this Agreement. The consideration to be received by Utimaco hereunder does not include compensation for the cost of insuring the risks and liabilities disclaimed by Utimaco. The limitations and disclaimers of Utimaco's obligations and liabilities are intended to apply to the fullest extent permitted by law, and the invalidity of application thereof to any given circumstance shall not affect such application to any other circumstance. Such limitations and disclaimers are intended to prevail over any provision in this Agreement to the contrary.

11. General

11.1 Governing Law. This Agreement and the performance of transactions under this Agreement will be governed by the laws of the State of New York, without regard to conflict of law principles, as if this Agreement was fully performed entirely within the State of New York except 1) in Germany, all disputes relating to this Agreement and the performance of transactions will be governed by German Law and will be submitted to the exclusive jurisdiction of the German Courts in Frankfurt/Main, 2) in the United Kingdom, all disputes relating to this Agreement and the performance of transactions will be governed by English Law and will be submitted to the exclusive jurisdiction of the English Courts, 3) in countries of the European Union which are not mentioned under no 1) or 2), all disputes relating to this Agreement and the performance of transactions will be governed by German Law and will be submitted to the exclusive jurisdiction of the German Courts, 4) in Japan all disputes relating to this Agreement and the performance of transactions will be governed by Japanese Law and will be submitted to the exclusive jurisdiction of the Tokyo District Court, in the first instance, 5) in all other countries, if legally permitted all disputes relating to this Agreement and the performance of transactions will be governed by German Law and will be submitted to the exclusive jurisdiction of the German Courts in Frankfurt/Main and if not legally permitted all disputes relating to this Agreement and the performance of transactions will be governed by the laws of the country in which the Software has been acquired. The United Nations' Convention on International Sale of Goods shall not apply to this Agreement. The parties each expressly waive any right to a jury trial regarding disputes related to this Agreement.

11.2 Jurisdiction; Attorney's Fees. Any dispute arising out of this Agreement shall be adjudicated exclusively in the courts of New York City, New York, except as otherwise set forth in Section 11.1. In any action or proceeding to enforce rights under this Agreement, the prevailing party will be entitled to recover costs and reasonable attorneys' fees from the other party.

11.3 Severability. If any provision of this Agreement is held to be invalid by a court of competent jurisdiction, then the remaining provisions shall nevertheless remain in full force and effect and the parties shall replace such provisions by a valid provision as close as possible to the original provision.

11.4 No Waiver. The failure of either party to enforce at any time any of the provisions of this Agreement shall not be deemed to be a waiver of the right of either party thereafter to enforce any such provisions.

11.5 Force Majeure. Except for the obligation to make payments, nonperformance of either party shall be excused to the extent that performance is rendered impossible by strike, fire, flood, governmental acts or orders or restrictions, failure of suppliers, or any other reason where failure to perform is beyond the reasonable control and not caused by the negligence of the nonperforming party.

11.6 Export Laws. You shall comply with all then current export laws and regulations of the U.S. Government and the government of the country in which you download or install the Software, which pertain to the Software.

11.7 Basis of Bargain. Each party recognizes and agrees that the warranty disclaimers and liability and remedy limitations in this Agreement are material bargained for bases of this Agreement and that they have been taken into account and reflected in determining the consideration to be given by each party to enter into this Agreement.

11.8 Mandatory Law. Consumers have legal (statutory) rights under applicable national laws relating to the sale of consumer products. This Agreement does not affect statutory rights you may have nor those rights that cannot be excluded or limited, nor rights against the person from whom you purchased the product. You may assert any statutory rights you have at your sole discretion.

11.9 Entire Agreement. This Agreement constitutes the entire, final, complete and exclusive agreement between the parties and supersedes all previous agreements or representations, oral or written, relating to this Agreement. This Agreement may not be modified or amended except in a writing signed by a duly authorized representative of each party. You acknowledge having read the terms and conditions set forth in this Agreement, understand all terms and conditions, and agree to be bound thereby. Utimaco's electronically or other properly stored copy of this Agreement shall be deemed to be the true, complete, valid, authentic and enforceable copy of this Agreement. You agree that you shall not contest the admissibility or enforceability of Utimaco's copy of this Agreement, as amended, in a court for any proceedings arising out of this Agreement. Your acceptance and this Agreement shall be deemed to be as effective as execution of this Agreement by a written signature performed manually by you, and this Agreement shall be deemed to satisfy any writings requirements of any applicable law, notwithstanding that the Agreement is written and accepted electronically. Utimaco's records of the date on which you accept this Agreement, and the effective date of all future changes to this Agreement, shall be conclusive evidence as to the effective date.

11.10 Restricted Rights Notice to U.S. Government. The Software is developed solely at private expense and delivered as "commercial computer software" as defined in DFARS 252.227-7013 (Oct. 1988), DFARS 252.211-7015 (May 1991) or DFARS 252.227-7014 (June 1995), as a "commercial item" as defined in FAR 2.101(a), DFARS 252.227-7015 (Nov. 1995) or FAR 52.227-14 (June 1987), or as "Restricted computer software" as defined in FAR 52.227.19 (June 1987), whichever is applicable. You have only those rights provided for such Software by the applicable FAR or DFARS clause or this Agreement. Manufacturer is Utimaco Safeware AG, Hohemarkstr. 22, 61440 Oberursel, Germany, except as otherwise agreed upon set forth in the offer, order confirmation, delivery note and / or invoice.

Part 2 - Country-unique Terms

GERMANY

The following Sections of Part 1 shall be replaced in whole as follows:

Section 8 (Limited Warranty) shall be replaced by the following Section 8:

8. Material Faults (Sachmängel) and Compensation of Expenses

8.1 Utimaco warrants that subject to contractually compliant use the Software meets the program description issued by Utimaco.

Where Utimaco's services deviate only marginally from the contractually agreed nature, this shall not entitle You to claims under material faults.

Furthermore, claims because of faults shall not arise in the event of excessive or improper use, natural wear and tear, failure of components in the system environment, software faults not reproducible or otherwise demonstrable by You or in the event of damage caused by particular external influences not expected under the Agreement. This shall also apply for subsequent change or repair by You or third party, unless this does not impede the analysis and rectification of a material fault.

Claims for damages and compensation of expenses shall also be governed by Section 10.

8.2 Claims because of a material fault shall be time-barred within one year from the delivery or - if installed by Utimaco - with completion of installation. This shall be without prejudice to the statutory periods for recourse under Section 478 German Civil Code (BGB) the same shall also apply in so far as the law under Section 438 Subsection 1 No. 2 German Civil Code (BGB) (buildings and items for buildings) stipulate longer periods, in the case of intentional or grossly negligent breach of duty by Utimaco, in the case of wilful non-disclosure of a fault and also in the event of fatalities, injury and impairment of health.

Utimaco's handling of warranty claim from You shall stay the warranty period only in so far as the statutory preconditions for this have been met. The warranty period shall not commence anew.

A subsequent performance (replacement delivery or repair) can influence the time bar of the fault triggering the subsequent performance.

8.3 You shall have warranty claims only if reported faults are reproducible or otherwise demonstrable by You.

8.4 If You are entitled to warranty claims, it shall initially have only the right to subsequent performance within a reasonable period of time. The subsequent performance includes either repair or provision of replacement software at the Utimaco`s discretion. Utimaco shall pay due heed to your interests when making the choice.

8.5 If the subsequent performance fails or cannot be carried out due to other reasons, subject to the statutory preconditions You can reduce the remuneration, rescind the Agreement and/or demand damages or compensation of expenses in the scope of Section 9.

You can exercise any choice it has with respect to warranty claims within a reasonable period of time, as a rule within 14 calendar days.

8.6 Utimaco can demand additional remuneration of its efforts in so far as (a) it acts in response to a report without there actually being a fault, unless You could not determine that there was no fault without making unacceptable efforts; or (b) a reported fault is not reproducible or otherwise demonstrable by You as a fault; or (c) additional effort is incurred because You have not properly complied with your duties.

Section 9 (Legal Faults) shall be replaced by the following Section 9:

9. Legal Faults (Rechtsmängel)

9.1 Utimaco shall be only liable for breach of third-party rights by its performance in so far as the performance is used as contractually agreed and in particular in the contractually envisaged use environment.

Utimaco shall be liable for breaches of third-party rights only within the European Union and the European Economic Area and also at the location of the contractually agreed use of the performance. Section 8.1 sentence 1 shall apply correspondingly.

9.2 If a third party claims against You that a performance by Utimaco breaches your rights, You shall immediately notify Utimaco. Utimaco and where appropriate its sub-suppliers shall be entitled but not obliged to defend such claims at their expense in so far as permitted.

You are not entitled to accept claims of any third party before he has given Utimaco the opportunity to put down the claims of the third party in another manner.

9.3 If a performance by Utimaco breaches third-party rights, Utimaco shall at its own discretion and expense (a) obtain for You the right to use the performance, or (b) render the performance such that it does not breach any rights; or (c) take back the performance and reimburse the remuneration rendered by You (less a reasonable deduction for use), if Utimaco cannot provide any other remedy without unreasonable effort and expense. Your interests shall be duly taken into consideration when the choice is made.

9.4 Your claims under legal faults shall be time-barred as per Section 8.2. Claims for damages and compensation of expenses shall also be governed by Section 10. Additional efforts of Utimaco are governed by Section 8.6 mutatis mutandis.

Section 10 (Limitation of Liability) shall be replaced by the following Section 10:

10. Utimaco's General Liability

10.1 Utimaco shall always be liable to You (a) for the losses caused by it and also its statutory representatives or agents intentionally or through gross negligence, (b) under the German Product Liability Act (Produkthaftungsgesetz); or losses relating to fatalities, injuries and impairment of health for which Utimaco, its statutory representatives or agents are answerable.

10.2 Utimaco shall not be liable in the event of minor negligence unless and in so far as it has breached a material duty (cardinal duty - Kardinalpflicht).

In the case of damage to property and financial losses, this liability is limited to typical losses foreseeable under such contracts. This shall also apply for foregone profit and savings not achieved. Liability for other more remote consequential damage is hereby excluded.

The liability for an individual incident is limited to the License Fee. The time bar shall be governed by Section 8.2 mutatis mutandis. The parties can negotiate and agree greater liability against separate remuneration. This shall be without prejudice to liability as per Section 10.1.

10.3 Utimaco shall be liable for damages under a guarantee only if this has been expressly agreed in the guarantee. In the event of minor negligence, this liability shall be governed by the limitations as per Section 10.2.

10.4 In the event of data loss, Utimaco shall be liable only for that effort and expense for restoring the data that would be necessary if You carried out proper data backup. In the case of minor negligence by Utimaco, this liability shall only apply if You properly backed up data immediately before the action leading to the loss of data.

10.5 Your claims for compensation of expenses and other liability claims against Utimaco shall be governed by Sections 10.1 to 10.4 mutatis mutandis.