Einleitung

SafeGuard PrivateCrypto bietet einen benutzerfreundlichen Weg zur Datenverschlüsselung. Eine oder mehrere Dateien und komplette Verzeichnisse können verschlüsselt werden. Die Struktur des Verzeichnisses bleibt nach der Verschlüsselung erhalten. Zusätzlich bietet SafeGuard PrivateCrypto die Möglichkeit, die verschlüsselten Dateien zu komprimieren.


Archive

Die Verschlüsselung und Komprimierung mehrerer Dateien und Verzeichnisse (Archive) wird unterstützt. Es ist möglich, einzelne Dateien zu einem Archiv ganz einfach hinzuzufügen oder aus einem solchen zu entfernen.
SafeGuard PrivateCrypto 1.x kann Archive, die mit der Version 2.x oder neuer erzeugt wurden, nicht öffnen.
SafeGuard PrivateCrypto 2.x kann Archive, die mit der Version 1.x erzeugt wurden öffnen, kann diese aber nicht verändern.
Die Integration in den Windows Explorer erlaubt die Verschlüsselung von Dateien, indem man sie im Windows Explorer mit der rechten Maustaste anklickt und ein Kennwort eingibt.
Um eine Datei zu entschlüsseln, reicht ein Doppelklick auf ein Archiv und die Eingabe eines Kennworts oder der Besitz des verwendeten Schlüssels. Um Benutzern, die SafeGuard PrivateCrypto nicht installiert haben, die Entschlüsselung zu ermöglichen, können selbst-extrahierende Programme erstellt werden. Solche Dateien können durch die Eingabe des Kennworts entschlüsselt werden.
Innerhalb der SafeGuard PrivateCrypto Benutzeranwendung ist es dem Benutzer möglich, Archive zu erstellen und zu verwalten (Dateien hinzufügen/löschen). Dateien können ganz einfach zu einem Archiv hinzugefügt werden, indem man sie in die SafeGuard PrivateCrypto Dateiliste in der Benutzeranwendung zieht. Dort können auch Voreinstellungen für die Verschlüsselung/Entschlüsselung (z. B. Standardordner für verschlüsselte Dateien) festgelegt werden (Dialog SafeGuard PrivateCrypto Optionen).


Schlüssel aus dem SafeGuard Enterprise Schlüsselring

SafeGuard PrivateCrypto erlaubt es, neben der Verschlüsselung durch Eingabe eines Kennworts auch Schlüssel aus dem SafeGuard Enterprise Schlüsselring für die Verschlüsselung zu verwenden. Ist SafeGuard Enterprise auf dem Computer installiert, können alle Schlüssel im Schlüsselring des Benutzers (von SafeGuard Enterprise zentral erzeugte oder auf dem SafeGuard Enterprise Client lokal erzeugte Schlüssel) verwendet werden.
So können SafeGuard PrivateCrypto Archive einfach zwischen SafeGuard Enterprise Benutzern ausgetauscht werden. Zur Entschlüsselung des Archivs muss der zur Verschlüsselung verwendete Schlüssel auf dem Computer vorhanden sein. Voraussetzung dafür ist, dass auf beiden Computern die Version 2.30 oder höher von SafeGuard PrivateCrypto verwendet wird.

HINWEIS:
Bitte beachten Sie, dass auf beiden Computern derselbe Schlüssel vorhanden sein muss (z. B. ein SafeGuard Enterprise Gruppenschlüssel). Wenn Sie einen SafeGuard Enterprise Schlüssel verwenden, der nicht im Schlüsselring des Empfängers enthalten ist, kann dieser das Archiv nicht entschlüsseln.
Wenn Sie lokal erzeugte SafeGuard Enterprise Schlüssel verwenden, müssen Sie dem Empfänger die Passphrase des Schlüssels mitteilen. Der Empfänger wird beim Öffnen des Archivs automatisch zur Eingabe dieser Passphrase aufgefordert.


Protokollierung (Kennwort-Historie)

Es ist möglich, eine Protokollierungsdatei zu erzeugen, in der das Kennwort, der Dateiname, das Datum der Verschlüsselung und (optional) ein Kommentar gespeichert werden. Diese Kennwort-Historie wird mit Hilfe eines zusätzlichen Kennworts oder eines SafeGuard Enterprise Schlüssels gesichert.
Das Kennwort müsste zusätzlich bei jeder Verschlüsselung eingegeben werden und kann deshalb gespeichert werden. Dabei ist zu beachten, dass dies ein Sicherheitsrisiko darstellt, weil die Speicherung des Kennworts nicht auf einem sicheren Weg erfolgen kann!
Wird ein SafeGuard Enterprise Schlüssel zur Sicherung verwendet, erfolgt das Abspeichern der Kennwörter ohne Benutzerinteraktion, wenn der verwendete Schlüssel im Schlüsselring des Benutzers vorhanden ist.


Verschlüsselte E-Mail-Anhänge

SafeGuard PrivateCrypto bietet die Möglichkeit, Dateien via E-Mail in einem Vorgang zu verschlüsseln und zu senden (siehe "Verschlüsseln & Senden", Seite 17). Nach der Verschlüsselung und der optionalen Komprimierung wird der E-Mail Client gestartet, und die Datei wird automatisch angehängt.


Algorithmen

SafeGuard PrivateCrypto benutzt den "Rijndael"-Algorithmus, der als der neue Advanced Encryption Algorithm (AES) gilt. Die Utimaco Implementierung benutzt den "Rijndael"-Algorithmus mit einer Schlüssellänge von 256 Bit, um Daten zu verschlüsseln. Zur Komprimierung wird die BZIP2-Bibliothek benutzt. Die Schlüssel für die Verschlüsselungsvorgänge werden unter Nutzung des PKCS#5 Kryptographie-Standards für Kennwörter abgeleitet.
SafeGuard PrivateCrypto ist erhältlich für Windows 2000, Windows XP und Windows Vista. SafeGuard PrivateCrypto ist als Freeware erhältlich und kann von der SafeGuard PrivateCrypto Homepage (www.utimaco.com/PrivateCrypto) für den persönlichen Gebrauch heruntergeladen werden.


Installation

Um SafeGuard PrivateCrypto für PC zu installieren, starten Sie das Setup-Programm durch einen Doppelklick auf sgpc231_German.exe oder sgpc231_German.msi (bzw. auf sgpc231_u_German.exe oder sgpc231_u_German.msi für die Installation der Privatanwenderversion). Ein Installationsassistent begleitet Sie durch den weiteren Installationsvorgang. Bitte folgen Sie den Anweisungen.


SafeGuard PrivateCrypto Benutzeranwendung

Um SafeGuard PrivateCrypto zu starten, klicken Sie auf Start > Programme > Utimaco > SafeGuard PrivateCrypto (bzw. den Ordner, den Sie während der Installation ausgewählt haben).
Neben den SafeGuard PrivateCrypto Explorer-Erweiterungen bietet SafeGuard PrivateCrypto die Möglichkeit, Archive über die SafeGuard PrivateCrypto Benutzeranwendung zu erzeugen und zu verwalten.
Dort können Dateien hinzugefügt und gelöscht sowie einzelne Dateien aus einem vorhandenen Archiv extrahiert werden.
Dateien (und Verzeichnisse!) können vom Windows Explorer in die PrivateCrypto-Dateiliste verschoben werden. Diese Dateien werden dann zur aktuellen Dateiliste hinzugefügt.
Die Dateiliste der SafeGuard PrivateCrypto-Benutzeranwendung zeigt alle Änderungen, die am aktuell ausgewählten Verschlüsselungsarchiv vorgenommen wurden:
Die Datei ist bereits Teil des Archivs und bleibt unverändert.
Die Datei wird zum Verschlüsselungsarchiv hinzugefügt.
Die Datei wird aus dem Verschlüsselungsarchiv herausgenommen.

Bitte beachten Sie, dass Änderungen in den Verschlüsselungsarchiven nur erfolgen, wenn die Datei gespeichert wird.
Unter Nutzung der Schaltfläche Auspacken oder dem Menü-Befehl Datei > Entschlüsseln können eine oder mehrere Dateien des Verschlüsselungsarchivs in der Liste ausgewählt und vom Archiv extrahiert (entschlüsselt) werden. Die verschlüsselten Versionen der Dateien bleiben innerhalb des Verschlüsselungsarchivs erhalten. Wenn keine Datei ausgewählt wird, extrahiert der Befehl Entschlüsseln standardmäßig alle Dateien des Archivs.
Werden ganze Verzeichnisse verschlüsselt, wird der entsprechende Pfad unter Pfad in der Listenansicht der SafeGuard PrivateCrypto Benutzeranwendung angezeigt.


SafeGuard PrivateCrypto-Optionen

Im Dialog SafeGuard PrivateCrypto Optionen (Extras > Optionen) können Voreinstellungen für Verschlüsselung/Entschlüsselung und die Kennwort-Historie festgelegt werden. Dies gilt für die SafeGuard PrivateCrypto Benutzeranwendung und für die Microsoft Windows Explorer-Erweiterungen. Die Einstellungen können auf Wunsch auch in den Dialogen Verschlüsselt Speichern und Entschlüsseln (Klicken Sie auf die Schaltfläche Optionen) für die aktuelle Operation einmalig geändert werden. Die Voreinstellungen selbst können nur innerhalb des Dialogs Optionen geändert werden. Der Dialog Optionen besteht aus drei Seiten:


Verschlüsselung

Voreinstellungen nach der Installation:
  • Standardordner: leer [Gleich wie Quelldatei]
  • Erzeuge ein selbst-extrahierendes Programm: nicht aktiviert
  • Sicheres Löschen der Quellendateien nach der Verschlüsselung: nicht aktiviert
  • Komprimiere Daten: aktiviert
Wenn diese Einstellungen geändert wurden, können Sie durch Drücken der Schaltfläche Standard wiederhergestellt werden.
Die hier getätigten Einstellungen gelten für alle Verschlüsselungsoperationen, die entweder mit der SafeGuard PrivateCrypto Benutzeranwendung oder über die Explorer Erweiterungen durchgeführt werden. Sie können temporär für eine einzige Verschlüsselungsoperation im Dialog Verschlüsseln überschrieben werden.
Das Anklicken von OK speichert die Einstellungen und schließt den Dialog Optionen.


Entschlüsselung

Voreinstellungen nach der Installation:
  • Standardordner: leer [Gleich wie Quelldatei]
  • Sicheres Löschen des Archivs nach dem Entschlüsseln aller Dateien: nicht aktiviert
Wenn diese Einstellungen geändert wurden, können Sie durch Drücken der Schaltfläche Standard wiederhergestellt werden.
Die hier getätigten Einstellungen gelten für alle Entschlüsselungsoperationen, die entweder mit der SafeGuard PrivateCrypto Benutzeranwendung oder über die Explorer Erweiterungen durchgeführt werden. Sie können temporär für eine einzige Entschlüsselungsoperation im Dialog Entschlüsseln überschrieben werden.
  • Standardordner:
    Standardmäßig werden alle Dateien in dieses Verzeichnis entschlüsselt. In der Drop-Down-Liste können dasselbe Verzeichnis wie jenes der Quelldatei und der Ordner Eigene Dateien ausgewählt werden. Ein weiteres Verzeichnis kann durch das Anklicken der Schaltfläche [...] ausgewählt werden.
  • Sicheres Löschen des Archivs nach dem Entschlüsseln aller Dateien:
    Wenn diese Option ausgewählt ist, wird das verschlüsselte Dateiarchiv nach der Entschlüsselung aller Dateien gelöscht (und kann daher nicht wiederhergestellt werden).
Das Anklicken von OK speichert die Einstellungen und schließt den Dialog Optionen.


Kennwort-Historie

Es ist möglich, eine Protokollierungsdatei zu erzeugen, in der das Kennwort, der Dateiname, das Datum der Verschlüsselung und (optional) ein Kommentar gespeichert werden. Diese Kennwort-Historie wird mit Hilfe eines zusätzlichen Kennworts oder eines SafeGuard Enterprise Schlüssels gesichert.
Das Kennwort müsste zusätzlich bei jeder Verschlüsselung eingegeben werden und kann deshalb gespeichert werden. Dabei ist zu beachten, dass dies ein Sicherheitsrisiko darstellt, da die Speicherung des Kennworts nicht auf einem sicheren Weg erfolgen kann!
Die Anzeige der Protokollierungsdatei ist nur über den Befehl Kennwort-Historie aus dem Menü Extras möglich.
Voreinstellungen nach der Installation:
  • Kennwort-Historie einschalten: deaktiviert
  • Datei für Kennwort Historie: keine
  • Kennwort für Historie in der Registry speichern: deaktiviert
Wenn diese Einstellungen geändert wurden, können Sie durch Drücken der Schaltfläche Standard wiederhergestellt werden.
Um Pfad und Namen, Kennwort, Datum der Erstellung und Anmerkungen für ein Archiv in einer separaten Datei zu speichern, muss die Option Kennwort-Historie einschalten aktiviert werden.
In einem zweiten Schritt können Name und Verzeichnis der Datei für die Kennwort-Historie spezifiziert werden.
Der Einfachheit halber kann das Kennwort für die Historie-Datei gespeichert werden. Es muss sonst jedesmal eingegeben werden, wenn ein Archiv erzeugt wird und das Kennwort in der Kennwort-Historie abgespeichert werden soll. Beachten Sie bitte, dass dies ein Sicherheitsrisiko darstellt!
Das Anklicken von OK speichert die Einstellungen und schließt den Dialog Optionen.


SafeGuard PrivateCrypto Kennwort-Historie

Ein Benutzer hat die Möglichkeit, seine Kennwörter in einer separaten Datei zu protokollieren. Falls der Benutzer beschließt, die Kennwörter in einer Datei zu protokollieren (was als solches ein Sicherheitsrisiko darstellt), gibt es folgende Möglichkeiten, diese Datei zu sichern:

HINWEIS:
Einstellungen zur Protokollierung in einer Kennwort-Historie haben bei der Verwendung von SafeGuard Enterprise Schlüsseln keine Auswirkung. Dementsprechend wird auch keine Aufforderung zur Eingabe eines Kennworts angezeigt, solange Sie SafeGuard Enterprise Schlüssel zur Verschlüsselung Ihrer Archive verwenden.

  • Eine Möglichkeit ist, ein Kennwort (das für die Verschlüsselung der Kennwort-Historie benutzt wird) für jede gewünschte Protokollierung einzugeben. Dies ist zwar sicher, aber nicht sehr benutzerfreundlich, da immer zwei Kennwörter eingegeben werden müssen; eines für das Archiv und das Kennwort für die Kennwort-Historie.
  • Die zweite Möglichkeit ist es, einen SafeGuard Enterprise Schlüssel für die Sicherung der Kennwort-Historie zu verwenden. Die Datei wird ohne Benutzerinteraktion verschlüsselt, wenn auf den Schlüssel im persönlichen Schlüsselring des Benutzers zugegriffen werden kann.
  • Eine weitere Möglichkeit ist, das Kennwort für die Kennwort-Historie abzuspeichern. Nur wenn der Benutzer die Kennwort-Historie einsehen will, muss dieses Kennwort nochmals eingegeben werden. In diesem Fall gibt es keinen sicheren Weg, das Kennwort und somit die Kennwort-Historie und alle enthaltenen Passwörter zu schützen!
Die eingestellte Datei für die Kennwort-Historie kann im Dialog Optionen eingesehen und geändert werden (Seite Kennwort-Historie).
Das Einsehen der Kennwort-Historie ist nur über den Befehl Kennwort-Historie ansehen aus dem Menü Extras möglich.
Pfad und Name, das Kennwort, das Datum der Erstellung und, optional, ein Kommentar für das Archiv werden in einer Liste angezeigt. Die Schaltfläche Kopieren kann benutzt werden, um den Inhalt der Kennwort-Historie in das Clipboard zu kopieren. Von dort aus kann der Inhalt für Archivierungszwecke in Textverarbeitungsprogramme übertragen werden.

HINWEIS:
Bitte stellen Sie sicher, dass das Clipboard geleert wird, nachdem es für das Kopieren der Kennwort- Historie benutzt wurde!


Neue Archive erzeugen

Neue Archive können mit SafeGuard PrivateCrypto auf folgende Weisen erzeugt werden:
1. Wählen Sie die Dateien bzw. Verzeichnisse im Windows Explorer aus.
Klicken Sie mit der rechten Maustaste und dann auf das PrivateCrypto Kommando im Kontextmenü SafeGuard PrivateCrypto. Daraufhin wird die SafeGuard PrivateCrypto Benutzeranwendung geöffnet.
Die ausgewählten Dateien werden in der Dateiliste der SafeGuard PrivateCrypto Benutzeranwendung angezeigt. Wenn ein Verzeichnis ausgewählt war, wird der Verzeichnisname unter Pfad angezeigt.
Wählen Sie Speichern.
Sie haben nun die Möglichkeit, ein Kennwort einzugeben oder einen SafeGuard Enterprise Schlüssel auszuwählen.
Kennwort:
Geben Sie ein Kennwort ein, bestätigen Sie es, und drücken Sie auf OK. Das Archiv wird im voreingestellten Zielordner für verschlüsselte Archive erzeugt:
Voreinstellungen (Zielverzeichnis, Optionen usw.) können im Dialog Optionen vorgenommen werden.

Schlüssel:
Sie können jeden beliebigen Schlüssel aus Ihrem SafeGuard Enterprise Schlüsselring auswählen.
Beachten Sie bitte den Unterschied zwischen automatisch erzeugten SafeGuard Enterprise Schlüsseln (Gruppenschlüssel, ...) und lokal erzeugten.
Wenn Sie einen automatisch erzeugten Schlüssel auswählen, kann das Archiv von jedem Benutzer, der diesen Schlüssel auch in seinem Schlüsselring hat, geöffnet werden.
Wenn Sie lokal erzeugte Schlüssel verwenden, kann ein Benutzer an den Sie dieses Archiv möglicherweise weitergeben wollen, das Archiv durch Eingabe der Passphrase für diesen Schlüssel öffnen.
Voraussetzung für beide Fälle ist, dass vom Empfänger die Version 2.30 oder höher von SafeGuard PrivateCrypto verwendet wird.
2. Öffnen Sie SafeGuard PrivateCrypto.
Fügen Sie Dateien durch Drag&Drop (Ziehen vom Explorer in die Dateiliste von SafeGuard PrivateCrypto) zur Dateiliste hinzu. Wenn Sie ein Verzeichnis hinüberziehen wird das ganze Verzeichnis hinzugefügt und die Verzeichnisstruktur wird ebenfalls mit abgespeichert.
Geben Sie ein Kennwort ein oder wählen Sie einen Schlüssel aus, bestätigen Sie es und drücken Sie auf OK. Das Archiv wird im voreingestellten Zielverzeichnis für verschlüsselte Archive erzeugt:
Voreinstellungen (Zielverzeichnis, Optionen usw.) können im Dialog Optionen vorgenommen werden.
3. Wählen Sie die Dateien bzw. Verzeichnisse im Windows Explorer aus.
Klicken Sie mit der rechten Maustaste und dann auf das Kommando Verschlüsseln im Kontextmenü SafeGuard PrivateCrypto.
Geben Sie ein Kennwort ein oder wählen Sie einen Schlüssel aus, bestätigen Sie es und drücken Sie auf OK. Das Archiv wird im voreingestellten Zielverzeichnis für verschlüsselte Archive erzeugt:
Voreinstellungen (Zielverzeichnis, Optionen, usw.) können im Dialog Optionen vorgenommen werden.


Verschlüsselt speichern

Um ein neues Archiv zu speichern
1. Klicken Sie auf die Schaltfläche Speichern in der SafeGuard PrivateCrypto Benutzeranwendung.
Der Dialog Verschlüsselt Speichern wird angezeigt.
2. Sie haben nun die Möglichkeit, ein Kennwort einzugeben oder einen SafeGuard Enterprise Schlüssel auszuwählen.
Kennwort:
Geben Sie ein Kennwort ein, bestätigen Sie es, und drücken Sie auf OK. Das Archiv wird im voreingestellten Zielordner für verschlüsselte Archive erzeugt:
Voreinstellungen (Zielverzeichnis, Optionen usw.) können im Dialog Optionen vorgenommen werden.
Schlüssel:
Sie können jeden beliebigen Schlüssel aus Ihrem SafeGuard Enterprise Schlüsselring auswählen.
Beachten Sie bitte den Unterschied zwischen automatisch erzeugten SafeGuard Enterprise Schlüsseln (Gruppenschlüssel, ...) und lokal erzeugten.
Wenn Sie einen automatisch erzeugten Schlüssel auswählen, kann das Archiv von jedem Benutzer, der diesen Schlüssel auch in seinem Schlüsselring hat, geöffnet werden.
Wenn Sie lokal erzeugte Schlüssel verwenden, kann ein Benutzer an den Sie dieses Archiv möglicherweise weitergeben wollen, das Archiv durch Eingabe der Passphrase für diesen Schlüssel öffnen.
Voraussetzung für beide Fälle ist, dass vom Empfänger die Version 2.30 von SafeGuard PrivateCrypto verwendet wird.
3. Das voreingestellte Zielverzeichnis (spezifiziert im Dialog Optionen) wird im Eingabefeld Archivdatei angezeigt.
Falls erforderlich, ändern Sie es. Das neue Zielverzeichnis ist nur für diesen einen Vorgang gültig.
4. Als Name für das Archiv wird standardmäßig der Name der ersten Datei auf der Dateiliste vorgeschlagen. Die Dateiendung .uti wird automatisch hinzugefügt.
Der Dateiname kann geändert werden.

HINWEIS:
Bitte lassen Sie die Dateiendung unverändert!

5. Klicken Sie auf OK.
Um ein Archiv zu speichern, können auch die Befehle Verschlüsselt speichern und Verschlüsselt speichern unter aus dem Menü Datei der SafeGuard PrivateCrypto Benutzeranwendung benutzt werden.


Öffnen vorhandener Archive

Um ein vorhandenes Archiv zu öffnen, genügt ein Doppelklick auf das Archiv im Windows Explorer.
Die SafeGuard PrivateCrypto Benutzeranwendung wird automatisch gestartet.
  • Ist die Protokollierung der Kennwort-Historie aktiviert und die Datei mit einem Kennwort gesichert, werden Sie zuerst aufgefordert, das Kennwort für die Kennwort-Historie Datei einzugeben. Anschließend müssen Sie das Kennwort für das Archiv eingeben. Danach wird der Inhalt des Archivs angezeigt.
  • Ist die Protokollierung der Kennwort-Historie aktiviert und die Datei mit einem SafeGuard Enterprise Schlüssel gesichert und der Schlüssel in Ihrem Schlüsselring vorhanden, wird das Archiv automatisch geöffnet.
Sie können auch den Befehl Öffnen aus dem Menü Datei der SafeGuard PrivateCrypto Benutzeranwendung oder die Schaltfläche Öffnen verwenden, um ein Archiv zu öffnen.
Um ein vorhandenes Archiv zu entschlüsseln, kann auch der Befehl Entschlüsseln aus dem SafeGuard PrivateCrypto Kontextmenü des Windows Explorers benutzt werden. Das Archiv wird dann sofort entschlüsselt. Abhängig von der gewählten Verschlüsselungsart (Kennwort oder ein Schlüssel aus dem SafeGuard Enterprise Schlüsselring), muss das Kennwort eingegeben werden oder der verwendete Schlüssel muss vorhanden sein-


Dateien einem Archiv hinzufügen

Um Dateien zu einem existierenden Archiv hinzuzufügen, benutzen Sie die Schaltfläche +. Wenn Sie die Schaltfläche anklicken, öffnet sich ein Dateiauswahldialog, mit dem Sie die Dateien auswählen können, die Sie hinzufügen wollen.
Ebenso kann man aus dem Menü Bearbeiten die Kommandos Hinzufügen oder Verzeichnis hinzufügen benutzen, um Dateien oder Verzeichnisse zu einem Archiv hinzuzufügen.
Noch komfortabler ist es, Dateien oder Verzeichnisse vom Explorer in SafeGuard PrivateCrypto hineinzuziehen.
Neu hinzugefügte Dateien werden in der Dateiliste mit einem grünen + angezeigt. Sie werden zum verschlüsselten Archiv hinzugefügt, wenn man die Schaltfläche Speichern in der Symbolleiste betätigt.


Dateien aus einem Archiv entfernen

Um Dateien aus einem vorhandenen Archiv zu entfernen, benutzen Sie die Schaltfläche -. Wählen Sie die zu entfernenden Dateien im PrivateCrypto Hauptfenster aus und klicken Sie auf die Schaltfläche -.
In einem ersten Schritt wird die Datei mit einem roten - markiert. Wirklich aus dem Archiv entfernt wird die Datei erst, wenn Sie die Schaltfläche Speichern in der SafeGuard PrivateCrypto Benutzeranwen- dung anklicken.
Anstelle der Schaltfläche - können Sie auch den Befehl Löschen aus dem Menü Bearbeiten der SafeGuard PrivateCrypto Benutzeranwendung oder die Taste Entfernen der Tastatur benutzten.


Dateien und Archive entschlüsseln

Zum Entschlüsseln von Dateien und Verzeichnissen
1. Wählen Sie die gewünschten Dateien in der Dateiliste der SafeGuard PrivateCrypto Benutzeranwendung aus.
2. Klicken Sie auf die Schaltfläche Auspacken in der Symbolleiste.
Der Dialog Entschlüsseln wird angezeigt.
3. Falls erwünscht, ändern Sie das Zielverzeichnis und wählen Sie die Option Sicheres Löschen des Archivs nach dem Entschlüsseln aller Dateien.
4. Klicken Sie auf OK.
Alle ausgewählten Dateien werden nun entschlüsselt und im Zielverzeichnis gespeichert.

HINWEIS:
Um ein ganzes Archiv zu entschlüsseln, ist es auch möglich, es im Windows Explorer auszuwählen und Entschlüsseln im Kontextmenü SafeGuard PrivateCrypto anzuklicken. Lediglich das Kennwort muss eingegeben werden. Wurde zum Verschlüsseln ein SafeGuard Enterprise Schlüssel verwendet, wird das Archiv automatisch entschlüsselt, wenn der verwendete Schlüssel verfügbar ist. Einzelne Dateien können nicht ausgewählt werden.


SafeGuard PrivateCrypto Explorer-Erweiterungen

Die Erweiterungen zum SafeGuard PrivateCrypto Explorer bieten einen einfachen Weg, Dateien und Verzeichnisse zu verschlüsseln. Zusätzlich erlauben sie es dem Benutzer, Dateien/Verzeichnisse zu verschlüsseln und diese direkt vom Windows Explorer aus per E-Mail zu versenden.
Wird mit der rechten Maustaste auf Dateien/Verzeichnisse geklickt, öffnet sich ein Kontextmenü mit dem Untermenü SafeGuard PrivateCrypto. Dieses enthält folgende Kommandos:
  • Verschlüsseln
    Zum Verschlüsseln von Dateien/Verzeichnissen direkt im Windows Explorer.
  • PrivateCypto
    Startet die SafeGuard PrivateCrypto Benutzeranwendung. Die ausgewählten Dateien/Verzeichnisse werden in der Dateiliste der Benutzeranwendung angezeigt. Dies gibt dem Benutzer die Möglichkeit, bestimmte Dateien hinzuzufügen oder zu löschen.
  • Verschlüsseln & Senden
Um Dateien und Verzeichnisse zu verschlüsseln und sie via E-Mail Client sofort zu senden.
Nachdem die Verschlüsselung abgeschlossen ist, wird der E-Mail Client gestartet und das verschlüsselte Archiv wird automatisch angehängt.

HINWEIS:
Das Senden von Archiven via E-Mail erfordert ein entsprechend konfiguriertes E-Mail-Programm auf Ihrem System!

    • SafeGuard PrivateCrypto benutzt die Windows-Funktion MAPI (Mail Application Program Interface) für die Kommunikation mit Ihrem E-Mail-Programm. Diese Standard-Schnittstelle erlaubt es SafeGuard PrivateCrypto und anderen Anwendungen, Ihr E-Mail-Programm zu kontrollieren (z. B. Verfassen einer Nachricht oder Dateien anhängen). Um eine angemessene Funktionalität zu gewährleisten, muss Ihr System folgende Anforderungen erfüllen:
    • Ihr E-Mail-Programm muss ein MAPI-kompatibles Mail-System sein.
    • Ihr E-Mail-Programm muss die "Simple MAPI"-Schnittstelle unterstützen, die für SafeGuard PrivateCrypto erforderlich ist.
    • Das E-Mail-Programm ist als Standard Mail Client ("primary MAPI client") konfiguriert.
  • Sicheres Löschen
    Ermöglicht das sichere Löschen von Dateien, sodass sie nicht wiederhergestellt werden können.


Verschlüsselung von Dateien

Verschlüsselung von Dateien mit SafeGuard PrivateCrypto:
1. Wählen Sie die Dateien im Windows Explorer aus.
2. Klicken Sie mit der rechten Maustaste auf die ausgewählten Dateien.
Das Kontext-Menü mit dem Eintrag SafeGuard PrivateCrypto wird angezeigt.
3. Klicken Sie auf Verschlüsseln.
Der Dialog Verschlüsselt Speichern wird angezeigt.
4. Sie haben nun die Möglichkeit, ein Kennwort einzugeben oder einen SafeGuard Enterprise Schlüssel auszuwählen.
Kennwort:
Geben Sie das Kennwort (höchstens 32 Zeichen) im Eingabefeld Kennwort ein und bestätigen Sie es im Eingabefeld Bestätigung.
Schlüssel:
Sie können jeden beliebigen Schlüssel aus Ihrem SafeGuard Enterprise Schlüsselring auswählen.
Beachten Sie bitte den Unterschied zwischen automatisch erzeugten SafeGuard Enterprise Schlüsseln (Gruppenschlüssel, ...) und lokal erzeugten.
Wenn Sie einen automatisch erzeugten Schlüssel auswählen, kann das Archiv von jedem Benutzer, der diesen Schlüssel auch in seinem Schlüsselring hat, geöffnet werden.
Wenn Sie lokal erzeugte Schlüssel verwenden, kann ein Benutzer an den Sie dieses Archiv möglicherweise weitergeben wollen, das Archiv durch Eingabe der Passphrase für diesen Schlüssel öffnen.
Voraussetzung für beide Fälle ist, dass vom Empfänger die Version 2.30 von SafeGuard PrivateCrypto verwendet wird.
5. Wünschen Sie ein selbst-extrahierendes Programm, aktivieren Sie die Option
Selbst-extrahierendes Programm erzeugen.
Archivdatei
Unter Archivdatei wird das voreingestellte Zielverzeichnis für verschlüsselte Archive, das im Dialog Optionen der SafeGuard PrivateCrypto Benutzeranwendung, ausgewählt wurde, angezeigt. Als Name für die verschlüsselte Datei/das Verzeichnis wird der Name der ersten Datei des Archivs vorgeschlagen. Standardmäßig wird die Dateiendung .uti an die verschlüsselte Datei angehängt. Wird die Dateiendung geändert, kann das Archiv unbrauchbar werden.
Benutzt man die Schaltfläche Durchsuchen neben dem Eingabefeld, kann ein anderer Zielordner für die verschlüsselte Quelldatei angegeben werden (der neue Pfad kann auch direkt im Eingabefeld für die Archivdatei eingegeben werden).
Wenn Sie auf die Schaltfläche Optionen klicken, bietet SafeGuard PrivateCrypto folgende weitere Optionen an:
Sicheres Löschen der Quelldateien nach der Verschlüsselung:
Ist diese Option aktiviert, wird die Quelldatei auf eine Art und Weise gelöscht, dass sie selbst mit entsprechenden Programmen nicht wiederhergestellt werden kann. Nur die verschlüsselte Version der Datei bleibt im System.

Daten komprimieren:
Komprimiert die ausgewählte Datei/ das Verzeichnis.
Bitte beachten Sie, dass die Komprimierung die Datei eventuell vergrößert, wenn sie auf sehr kleine Dateien, oder auf Dateien, die bereits komprimiert wurden, angewendet wird. Die zur Archiverstellung benötigte Zeit ist bedeutend länger, wenn die Komprimierung aktiviert ist.

Kennwort in der Kennwort-Historie merken:
Das verwendete Kennwort wird in der Kennwort-Historie gespeichert.

HINWEIS:
Die Voreinstellungen für diese Optionen sind im Dialog Optionen der SafeGuard PrivateCrypto Benutzeranwendung festgelegt. Werden sie im Dialogfeld geändert, werden die vorgegebenen Einstellungen nur für diesen Verschlüsselungsvorgang außer Kraft gesetzt.

6. Klicken Sie auf OK.


Entschlüsselung von Dateien

Zum Entschlüsseln von Dateien mit SafeGuard PrivateCrypto:
1. Wählen Sie das Archiv im Windows Explorer aus.
2. Klicken Sie mit der rechten Maustaste auf das ausgewählte Archiv.
Das Kontextmenü mit einem SafeGuard PrivateCrypto Eintrag wird angezeigt.
3. Klicken Sie auf Entschlüsseln.
Der Dialog Entschlüsseln wird angezeigt.
  • Wurde das Archiv mit einem Kennwort verschlüsselt, werden Sie aufgefordert, dieses einzugeben.
    Nach dem Klicken auf OK wird das Archiv entschlüsselt.
HINWEIS:
Wenn Sie ein falsches Kennwort eingeben, verlängert sich die Wartezeit nach jedem Versuch.
Wenn Sie auf die Schaltfläche Optionen klicken, bietet Utimaco SafeGuard PrivateCrypto folgende zusätzlichen Optionen an:
Archivdatei
Unter Archivdatei wird das voreingestellte Zielverzeichnis für verschlüsselte Archive, welches im Dialog Optionen der SafeGuard PrivateCrypto Benutzeranwendung ausgewählt wurde, angezeigt. Benutzt man die Schaltfläche Durchsuchen neben dem Eingabefeld, kann ein beliebiger Ordner, in dem die verschlüsselte Datei gespeichert werden soll, spezifiziert werden (der neue Pfad kann auch direkt im Eingabefeld angegeben werden).
Sicheres Löschen des Archivs nach dem Entschlüsseln aller Dateien
Ist diese Option aktiviert, wird das Archiv nach dem Entschlüsseln aller Dateien sicher gelöscht (und kann nicht wiederhergestellt werden). Nur die entschlüsselte Dateien bleibem im System.

HINWEIS:
Diese Optionen sind im Dialog Optionen der SafeGuard PrivateCrypto Benutzeranwendung voreingestellt. Werden sie im Dialogfeld geändert, werden die vorgegebenen Einstellungen nur für diesen Entschlüsselungsvorgang außer Kraft gesetzt.

  • Wurde das Archiv mit einem SafeGuard Enterprise Schlüssel verschlüsselt und der Schlüssel ist in Ihrem Schlüsselring vorhanden, wird das Archiv automatisch entschlüsselt.


Selbst-extrahierende Programme erzeugen

SafeGuard PrivateCrypto erlaubt Ihnen, selbst-extrahierende Programme zu erzeugen. Der Vorteil von selbst-extrahierenden Archiven liegt darin, dass sie auch von Benutzern entschlüsselt werden können, die SafeGuard PrivateCrypto nicht installiert haben. Um sie zu entschlüsseln, benötigt man lediglich das Kennwort oder die Passphrase für einen lokal erzeugten SafeGuard Enterprise Schlüssel.
SafeGuard PrivateCrypto kann auch selbst-extrahierende Programme unter der Verwendung von lokal erzeugten SafeGuard Enterprise Schlüsseln erzeugen. Diese .exe Dateien können auch auf Computern ohne SafeGuard PrivateCrypto und ohne SafeGuard Enterprise entschlüsselt werden. Beim Starten eines solchen Programms wird der Benutzer aufgefordert, die Passphrase des lokalen Schlüssels einzugeben. Diese muss dem Empfänger vorher bekanntgegeben werden.
Die Passphrase wird beim Erzeugen eines lokalen Schlüssels für SafeGuard Enteprise festgelegt.
Um ein selbstextrahierendes Archiv mit SafeGuard PrivateCrypto zu erzeugen:
1. Wählen Sie eine Datei im Windows Explorer aus.
2. Klicken Sie mit der rechten Maustaste auf die ausgewählte Datei.
Ein Kontextmenü mit dem Eintrag SafeGuard PrivateCrypto wird angezeigt.
3. Wählen Sie Verschlüsseln aus.
Der Dialog Verschlüsselt Speichern wird angezeigt.
4. Sie haben nun die Möglichkeit, ein Kennwort einzugeben oder einen SafeGuard Enterprise Schlüssel auszuwählen.
Kennwort:
Geben Sie das Kennwort (höchstens 32 Zeichen) im Eingabefeld Kennwort ein und bestätigen Sie es im Eingabefeld Bestätigung.
Schlüssel:
Für selbst extrahierende Programme können Sie einen lokal erzeugten SafeGuard Enterprise Schlüssel verwenden. Um die Datei zu entschlüsseln, muss der Empfänger die Passphrase für diesen Schlüssel eingeben. Die Passphrase wird beim Erzeugen des Schlüssels in SafeGuard Enterprise festgelegt.
5. Aktivieren Sie die Option Selbst-extrahierendes Programm erzeugen.
Archivdatei
Unter Archivdatei wird das voreingestellte Zielverzeichnis für verschlüsselte Archive, das im Dialog Optionen der SafeGuard PrivateCrypto Benutzeranwendung ausgewählt wurde, angezeigt. Als Name für die verschlüsselte Datei/das Verzeichnis wird der Name der ersten Datei des Archivs vorgeschlagen. Standardmäßig wird die Dateiendung .uti an die verschlüsselte Datei angehängt. Wird die Dateiendung geändert, kann das Archiv unbrauchbar werden.
Benutzt man die Schaltfläche [...] neben dem Eingabefeld, kann ein anderer Zielordner für die verschlüsselte Quelldatei, angegeben werden (der neue Pfad kann auch direkt im Eingabefeld für die Archivdatei eingegeben werden).
Wenn Sie auf die Schaltfläche Optionen klicken, bietet SafeGuard PrivateCrypto folgende weitere Optionen an:
Sicheres Löschen der Quelldateien nach der Verschlüsselung:
Ist diese Option aktiviert, wird die Quelldatei auf eine Art und Weise gelöscht, dass sie selbst mit entsprechenden Programmen nicht wiederhergestellt werden kann. Nur die verschlüsselte Version der Datei bleibt im System.
Daten komprimieren:
Komprimiert die ausgewählte Datei/ das Verzeichnis.
Bitte beachten Sie, dass die Komprimierung die Datei eventuell vergrößert, wenn sie auf sehr kleine Dateien angewendet wird, oder auf Dateien, die bereits komprimiert wurden. Die zur Archiverstellung benötigte Zeit ist bedeutend länger, wenn die Komprimierung aktiviert ist.
Kennwort in der Kennwort-Historie merken:
Das verwendete Kennwort wird in der Kennwort-Historie gespeichert.
6. Klicken Sie auf OK.


Mindestlänge von Kennwörtern

SafeGuard PrivateCrypto bietet die Möglichkeit, eine Mindestlänge für Kennwörter festzulegen. Dazu kann der DWORD Eintrag PasswordLengthMin unter folgendem Schlüssel in der Windows-Registrierung abgelegt werden:
HKEY_LOCAL_MACHINE\SOFTWARE\UTIMACO\SGPC
Legen Sie einen Wert für PasswordLengthMin fest, der die Mindestlänge für Kennwörter definiert
(in Zeichen).


SafeGuard PrivateCrypto Command Line-Schnittstelle

Die Command Line Syntax für SafeGuard PrivateCrypto ist wie folgt (rufen Sie pcrypt vom Installationsverzeichnis von SafeGuard PrivateCrypto auf):
pcrypt [Pfad und Name der Quelldatei] [Optionen]
Optionen:

-e<Archiv> | erstellt das vorhandene Verschlüsselungsarchiv. Wird kein Archiv angegeben, wird der Name der ersten Datei benutzt (und die Endung .uti).
-d<Archiv> | entschlüsselt das vorhandene Archiv.
-a<Archiv> | fügt die gegebenen Dateien zu einem vorhandenen Archiv hinzu. Falls das Zielarchiv noch nicht existiert, wird es erstellt.
-x<Archiv> | erstellt ein selbst-extrahierendes Programm.
-o<Verzeichnis> | Output Verzeichnis (nur für Entschlüsselung)
-p<Kennwort> | Kennwort für Verschlüsselung/Entschlüsselung
-l<Kennwort> | Kennwort für Kennwort-Historie
-m | Senden des Archivs nach der Verschlüsselung.
-n | verbirgt die Benutzerschnittstelle, zeigt jedoch Fehlermeldungen an.
-q | verbirgt die Benutzerschnittstelle und Fehlermeldungen.
-c[+|-] | komprimiert Daten während der Verschlüsselung.
-s[+|-] | löscht die Quelldatei(en) nach der Verschlüsselung/Entschlüsselung
-t[+|-] | überschreibt vorhandene Zieldateien.
-h | zeigt die Commandline Syntax an
-w | löscht Dateien. Kann nicht mit Verschlüsselung und Entschlüsselung kombiniert werden.
-aes256 | verwendet den AES-256 Algorithmus. Gilt nur für neue Archive. Default wie in den SafeGuard PrivateCrypto Optionen voreingestellt.
@<file> | Dateinamen, die mit "@" beginnen, werden als Kontrolldateien verstanden, die zusätzliche Dateinamen und Optionen enthalten können. Dies erlaubt das Übertragen großer Command Line Strings, das normalerweise aufgrund der Restriktion der Größe der Command Lines nicht möglich wäre.

Beispiele:
pcrypt utimaco.txt -e -oC:\Encrypted\Utimaco_Enc.txt -p12345678 -n
-s
Die Datei utimaco.txt wird verschlüsselt und als Utimaco_Enc.txt.uti (die Dateiendung .uti wird automatisch angehängt) im Verzeichnis C:\Encrypted abgespeichert. Das Kennwort für das Entschlüsseln der Datei lautet 12345678. Weil -n spezifiziert wurde, wird keine Benutzerschnittstelle angezeigt (z. B. um ein Kennwort einzugeben). Die Quelldatei, die sich im selben Verzeichnis befindet, aus dem pcrypt aufgerufen wurde, wird nach der Verschlüsselung gelöscht (-s).
Erstellen eines Archivs mit zwei Dateien:
Pcrypt test.txt test2.txt -etest.uti -psecret
Hinzufügen einer dritten Datei und eines Verzeichnisses, das Dateien enthält (unter Zurückgreifen auf das obere Archiv):
Pcrypt test3.txt c:\winnt -atest.uti -psecret
Dateien von einem Archiv extrahieren:
Pcrypt -dtest.uti test.txt test2.txt -psecret


SafeGuard PrivateCrypto OLE Automations-Schnittstelle

SafeGuard PrivateCrypto enthält einen OLE Automations-Server, der für den programmatischen Gebrauch von SafeGuard PrivateCrypto innerhalb aller Anwendungen, die mit dem Windows-Scripting kompatibel sind, benutzt werden kann. Dies schließt den Windows Scripting Host (unterstützt Visual Basic Scripting, JavaScript, Perl, ...) genauso wie Microsoft Office Anwendungen, Web-Seiten und Programmierumgebungen wie Visual Basic, Visual C++ und viele andere mehr, ein.
Die Exportklasse wird als "PrivateCrypto.Archive" bezeichnet. Für die Scripting-Kompatibilität exportiert sie eine Idispatch-Schnittstelle mit folgenden Befehlen und Eigenschaften:
Eigenschaften:
Die Eigenschaften der PrivateCrypto.Archive Objekte sind so voreingestellt, wie es in den Optionen von SafeGuard PrivateCrypto definiert ist. Werden die Eigenschaften eines Archivobjektes geändert, betrifft dies nur nachfolgende Vorgänge dieses einzelnen Objekts. Die Gesamteinstellungen werden jedoch nicht verändert.

CompressData
Boolean
Komprimierung an/aus.
DecryptDeleteSource
Boolean
Sicheres Löschen des Verschlüsselungsarchivs, nachdem alle Dateien extrahiert wurden.
Dies geschieht nur, wenn alle Dateien des Archivs erfolgreich extrahiert wurden.
Wird eine einzelne Datei extrahiert, wird dadurch nicht das gesamte Archiv gelöscht, selbst wenn es die einzige Datei des Archivs ist.
DecryptFolder
String
Zielordner des verschlüsselten Archivs.
EncryptDeleteSource
Boolean
Sicheres Löschen der Quelldateien, nachdem sie erfolgreich zum Verschlüsselungsarchiv hinzugefügt wurden.
EncryptFolder
String
Zielordner für Verschlüsselungsarchive.
EncryptAlgorithm
Integer
Verschlüsselungsalgorithmus für das neue Archiv.
Default wie voreingestellt in den PrivateCrypto Optionen.
Unterstützte Werte:
2=AES-256
NoGui
Boolean
Diese Option kann auf True gesetzt werden, wenn kein GUI gezeigt werden soll. In diesem Fall werden weder Dialoge noch Fehler oder Warnungen angezeigt.
Standardmäßig wird diese Option auf False gesetzt. Daraus ergibt sich, dass nach Kennwörtern gefragt wird, wenn sie nicht bereits als Befehlsparameter angegeben sind.
Wenn die "NoGui"-Eigenschaft auf True gesetzt wurde, aber eine Benutzer-Interaktion erforderlich ist (z. B. Eingabe eines Kennworts), wird der gesamte Vorgang gelöscht und ein entsprechender Fehlercode zurückgeschickt.
PasswordLogEnabled
Boolean
Soll das Kennwort in der Kennwort-Historie protokolliert werden, wenn ein Verschlüsselungsarchiv erzeugt wird.

Befehle:
Dies ist die Liste der Befehle, die für PrivateCrypto.Archive aufgerufen werden können. Die in Klammern gesetzten Parameter sind optional. Weiter unten finden Sie eine Beschreibung der einzelnen Parameter:
AddFiles archive, files, pwd, (logpwd), (comment) | Eine oder mehrere Dateien zu einem Verschlüsselungsarchiv hinzufügen. Wenn das Archiv nicht bereits existiert, wird es erzeugt.
CreateSFX archive, files, (pwd), (logpwd), (comment) | Erzeugen eines selbst-extrahierenden Programms, das eine oder mehrere Dateien enthält.
Decrypt archive, (files), (pwd) | Extrahieren von einer, mehreren oder aller Dateien aus einem Verschlüsselungsarchiv. Die Datei-Parameter können hier optional sein. In diesem Fall werden alle Dateien aus dem Archiv extrahiert.
Encrypt archive, files, (pwd), (logpwd) | Erzeugen eines neuen Verschlüsselungsarchivs, das aus einer oder mehreren Dateien besteht. Falls die Zieldatei bereits besteht, wird der Benutzer gefragt, ob sie überschrieben werden soll oder nicht.
RemoveFiles archive, files, (pwd) | Entfernen von einer oder mehreren Dateien aus einem Verschlüsselungsarchiv. Die Dateien sind nicht entschlüsselt, sondern werden einfach aus dem Archiv entfernt. Das Kennwort wird nur für Authorisierungs-Zwecke benutzt.
Parameter:
archive | Name des Verschlüsselungsarchivs. Dieser ist für alle Befehle erforderlich.
files | Darunter versteht man entweder einen einzelnen Dateinamen oder eine Reihe von Dateinamen. Weiter unten finden Sie ein Beispiel, wie man eine Reihe von Dateinamen spezifiziert.
pwd | Das Kennwort für das Verschlüsselungsarchiv. Wird ein neues Archiv erzeugt und ist die Kennwortprotokollierung aktiviert, wird das Kennwort für das Archiv in die Kennwort- Historie geschrieben. Wird kein Kennwort angegeben, wird der Benutzer nach dem Kennwort gefragt.
logpwd | Das Kennwort für die Kennwort-Historie. Soll ein Eintrag zur Kennwort-Historie hinzugefügt werden, wird das Kennwort für den Zugang zur Kennwort-Historie benötigt. Das Kennwort ist nicht erforderlich, wenn es in der Registrierung gespeichert ist.
comment | Der Kommentar für den Eintrag in der Kennwort Historie.


Beispiel-Skript

Hier ein Sample eines VBScript Codes, das die Verwendung aller unterstützten OLE Automatisierungsfunktionen demonstriert :
language = "VBScript"
'=================================================================
'
' This script demonstrates the SafeGuard® PrivateCrypto OLE automation object.
' During the demo, files are created in the "c:\demo" directory.
'
'=================================================================
On Error Resume Next
'
' Define the name of the directory used by this demo.
' This will automatically be created, if necessary.
'
sFolder = "c:\demo"
'
' Create the necessary files for this demo
'
Call Install(sFolder)
'
' Declare and create our object for interfacing SafeGuard® PrivateCrypto
'
Dim pc
Set pc = CreateObject ("PrivateCrypto.Archive")
'
' Set encryption options
'
pc.CompressData = True
pc.EncryptDeleteSource = False
'
' Create an encryption archive, holding all files from the "files" subdirectory
'
If Not pc.Encrypt(sFolder & "\test.uti", sFolder & "\files", "secret") then
MsgBox pc.GetErrorText
End If
'
' Create a self-extracting executable from a given
' list of files. Note that if one of the given file names
' represents a directory, all files within this directory
' are used. Further, the optional log file password parameter
' is filled out here.
'
Dim arrayCreate(2)
arrayCreate(0) = sFolder & "\files"
arrayCreate(1) = sFolder & "\test.uti"
If Not pc.CreateSFX(sFolder & "\test.exe", arrayCreate, "secret", "logpwd") then
MsgBox pc.GetErrorText
End If
'
' Decrypt all files from an archive to a given location.
' Note that the empty files array parameter (par #2) specifies
' to extract all files.
'
pc.DecryptFolder = sFolder & "\decrypt"
If Not pc.Decrypt(sFolder & "\test.uti", ,"secret") then
MsgBox pc.GetErrorText
End If
'
' Remove a list of files from an archive
'
Dim arrayRemove(2)
arrayRemove(0) = "files\test2.txt"
arrayRemove(1) = "files\test3.txt"
If Not pc.RemoveFiles(sFolder & "\test.uti", arrayRemove, "secret") then
MsgBox pc.GetErrorText
End If
'
' Add a single file to an encryption archive
'
If Not pc.AddFiles(sFolder & "\test.uti", sFolder & "\files\test2.txt", "secret") then
MsgBox pc.GetErrorText
End If
'
' Free the SafeGuard® PrivateCrypto automation object
'
Set pc = nothing
MsgBox "End of demo. Generated files can be found in folder " & sFolder & "."
'
'-----------------------------------------------------------
' Helper routine to set-up files used by the demo script
'-----------------------------------------------------------
'
Sub Install (sFolder)
On Error Resume Next
Dim fso
Dim file
'
' Create a filesystem-object
'
Set fso = CreateObject("Scripting.FileSystemObject")
'
' Create directories used by the demo
'
fso.CreateFolder sFolder
fso.CreateFolder sFolder & "\files"
'
' Delete old files from earlier runs of this demo
'
fso.DeleteFile sFolder & "\test.uti"
fso.DeleteFile sFolder & "\test.exe"
fso.DeleteFile sFolder & "\decrypt\*.*"
fso.DeleteFile sFolder & "\decrypt\files\*.*"
'
' Create input files for the demo
'
    Set file = fso.CreateTextFile(sFolder & "\files\
    test1.txt", True)
file.WriteLine("This is a demo text file.")
file.Close
fso.CopyFile sFolder & "\files\test1.txt", sFolder &
    "\files\test2.txt"
fso.CopyFile sFolder & "\files\test1.txt", sFolder &
    "\files\test3.txt"
Set fso = nothing
End Sub


SOFTWARE LIZENZ- UND NUTZUNGSVEREINBARUNG

(Stand: 15. Oktober 2007)
Durch Fortsetzung des Download- bzw. Installationsvorganges erklären Sie sich mit den Bedingungen der nachfolgenden Lizenz- und Nutzungsvereinbarung ausdrücklich einverstanden.

Teil 1 - Allgemeine Bedingungen

1. Gegenstand dieser Vereinbarung

Gegenstand dieser Vereinbarung sind das von Utimaco nach Maßgabe dieser Vereinbarung zur Verfügung gestellte Programm, die Programmbeschreibung, die Bedienungsanleitung und das zusätzliche Begleitmaterial und/oder Dokumentation, einschließlich der Programme, die Dritte Utimaco Safeware AG („Utimaco") zur Distribution im Zusammenhang mit Utimaco Produkten zur Verfügung gestellt haben, ("Software"). Utimaco weist darauf hin, dass es nach dem gegenwärtigen Stand der Technik nicht möglich ist, Computersoftware so zu erstellen, dass sie in allen Anwendungen und Hardwarekombinationen fehlerfrei arbeitet. Gegenstand dieser Vereinbarung ist daher nur Software, die grundsätzlich im Sinne der Programmbeschreibung, der Bedienungsanleitung und anderer diese Software begleitender Dokumentation brauchbar ist. Sie erkennen an und sind damit einverstanden, dass aus dem Hinweis auf Utimaco`s Lizenzgeber im Zusammenhang mit der Software keine vertragliche Beziehung zwischen diesem Lizenzgeber und Ihnen bezüglich der Rechte aus diesem Vertrag hergeleitet werden können, und Sie werden nur gegenüber Utimaco und/oder seinen Händlern und Distributoren Rechte aus diesem Vertrag geltend machen.

2. Nutzungsumfang, Download / Installation der Software

2.1 Nach Annahme dieser Bedingungen und vorbehaltlich der Zahlung der Lizenzvergütung (Artikel 7) haben Sie das nicht ausschließliche, nicht übertragbare Recht die Software auf der Anzahl von Computern oder Netzwerk-Servern wie in Auftragsbestätigungen, Lieferscheinen und / oder Rechnungen angegeben für die Dauer dieser Vereinbarung zu nutzen. Eine darüber hinausgehende Nutzung ist ausdrücklich untersagt. Diese Lizenz stellt keinen Verkauf der Software oder eines Teiles oder einer Kopie derselben dar.

2.2 Nach Annahme dieser Bedingungen dürfen Sie die Software und Dokumentation herunterladen und installieren. Die Software gilt mit diesem Download als angenommen. Wenn eine Funktion oder ein Modul der Software eine Gewährleistung verletzt, sind Sie verpflichtet, Utimaco innerhalb der in Artikel 8 dieser Vereinbarung festgelegten Gewährleistungsfrist zu benachrichtigen und eine detaillierte Beschreibung der Mängel zur Verfügung zu stellen. Die Gewährleistungsrechte sind in Artikel 8 abschließend dargestellt.

3. Besondere Beschränkungen, Updates

Die Lizenzrechte unterliegen den folgenden Beschränkungen:

3.1 Sie stimmen zu, dass alle zukünftigen Änderungen, Verbesserungen, Updates, Revisionen und/oder neuen Versionen der Software, die von Utimaco (oder ggfs. seinen Lizenzgebern) erstellt werden, das alleinige Eigentum von Utimaco (oder ggfs. seinen Lizenzgebern) sein werden.

3.2 Sie dürfen eine angemessene Anzahl Kopien der Software ausschließlich für Archiv- und Backup-Zwecke erstellen, sofern alle Copyright-Vermerke oder anderen eigentumsrechtlichen oder beschränkenden Hinweise oder Mitteilungen von Utimaco auf allen diesen Kopien reproduziert werden.

3.3 Sie bewahren die Software in strikter Vertraulichkeit auf und offenbaren diese ohne ausdrückliche schriftliche Zustimmung von Utimaco keinem Dritten (außer wie durch diese Vereinbarung gestattet). Utimaco stimmt hiermit der Offenlegung der Software für Ihre Mitarbeiter und Vertragspartner zu, vorausgesetzt, dass ein solcher Mitarbeiter oder Vertragspartner diese urheberrechtlich geschützten Informationen im Rahmen seiner Tätigkeit kennen muss.

3.4 Außer den in diesem Vertrag ausdrücklich und eindeutig festgelegten Lizenzrechten erkennen Sie an, dass Utimaco oder ggfs. seine Lizenzgeber alle Rechte am Original und allen Kopien der Software und der Dokumentation behält, ob in maschinenlesbarer oder gedruckter Form (und ohne Einschränkung einschließlich abgeleiteter Arbeiten, Zusammenstellungen oder Sammlungen derselben und allen damit zusammenhängenden technischen Know-how und allen Rechten daran), und dass jegliches Eigentum an sämtlichen Patenten, Urheberrechten, Warenzeichen, Handelsnamen, Industriegeheimnissen, Technologien, Ideen, Know-how und anderen geistigen Eigentumsrechten das alleinige Eigentum von Utimaco oder ggfs. seinen Lizenzgebern ist und bleibt. Sie sind kein Eigentümer der Software, oder einer Kopie derselben, sondern die Software ist nur für die Installation und den Gebrauch solcher Kopien nach dieser Vereinbarung lizenziert. Außer den hiernach ausdrücklich und eindeutig gewährten Rechten behält sich Utimaco oder ggfs. seine Lizenzgeber alle Rechte in und an der Software und Dokumentation für sich selbst vor. Sie werden nichts tun, um das Eigentum von Utimaco oder ggfs. seinen Lizenzgebern an bzw. die Rechte bezüglich der Software und Dokumentation in irgendeiner Weise zu gefährden, zu beschränken oder in diese einzugreifen.

3.5 Sie sind verantwortlich für (i) die Auswahl, Effizienz und Eignung der Software für Ihren Geschäftszweck; (ii) den Gebrauch der Software gemäß der von Utimaco gelieferten Dokumentation; (iii) alle Ansprüche aus Verletzung infolge Ihrer Kombination der Software mit Daten oder anderer Software oder Geräten, die nicht von Utimaco geliefert oder schriftlich genehmigt wurden; oder (iv) die Installation der Software.

3.6 Außer ausdrücklich in dieser Vereinbarung vorgesehen, oder in dem nach geltendem Recht erlaubten Umfang, werden Sie (i) die Software weder direkt noch indirekt kopieren, modifizieren, übersetzen, rückkompilieren, disassemblieren, rückentwickeln oder auf andere Weise den Quellcode der Software ermitteln oder zu ermitteln suchen, oder abgeleitete Arbeiten auf der Basis der Software oder Dokumentation erstellen, noch (ii) Änderungen, Verbesserungen, Updates, Revisionen und / oder neue Versionen der Software erstellen.

3.7 Sie werden Utimaco unverzüglich schriftlich informieren über jeden tatsächlichen oder vermuteten Verstoss gegen eine wesentliche Verpflichtung nach dieser Vereinbarung, die Ihnen bekannt wird, und Sie kooperieren mit Utimaco bei allen rechtlichen Maßnahmen zur Verhinderung oder Einstellung des unberechtigten Gebrauchs, der Reproduktion oder Verteilung der Software oder Dokumentation.

4. Übertragung der Nutzungsrechte

Ohne die vorherige schriftliche Zustimmung von Utimaco haben Sie kein Recht, die sich aus diesem Vertrag ergebenden Rechte oder Pflichten an Dritte zu verkaufen, unterlizenzieren, übereignen, übertragen, zu überlassen oder auf andere Weise darüber zu verfügen.

5. Reproduktion des Urheberrechtsvermerks

Die Software und die begleitenden Schriften sind urheberrechtlich geschützt. Ein in der Software enthaltener Urheberrechtsvermerk und eine darin enthaltene Registriernummer dürfen nicht entfernt werden.

6. Dauer dieser Vereinbarung

Diese Vereinbarung läuft auf eine unbestimmte Zeit, sofern sie nicht gemäß den Bestimmungen dieser Vereinbarung früher gekündigt wird. Jede Partei kann diese Vereinbarung schriftlich kündigen, wenn die andere Partei (i) einen wesentlichen oder andauernden Verstoß gegen diese Vereinbarung begeht, sofern er nicht innerhalb von dreißig (30) Tagen ab schriftlicher Kündigungsmitteilung beseitigt wird, oder (ii) zahlungsunfähig wird, eine generelle Übertragung zu Gunsten ihrer Gläubiger vornimmt, einen Insolvenzantrag stellt, ein Verwalter über ihr Geschäft oder Vermögen bestellt wird, oder ein Insolvenzverfahren durchgeführt wird, jeweils unabhängig von inländischem oder ausländischem Recht, oder freiwillig oder anderweitig abgewickelt oder liquidiert wurde. Im Falle einer Kündigung Ihrer Lizenz (i) müssen Sie die Software löschen oder an Utimaco zurückgeben, einschließlich aller Kopien der Software, aller geänderten Teile und der Dokumentation,(ii) enden automatisch alle Rechte, die Ihnen im Rahmen dieser Vereinbarung gewährt wurden. Alle Ausschlüsse, Haftungsbeschränkungen, Freistellungen und anderen Beschränkungen, die in dieser Vereinbarung enthalten sind, gelten auch nach der Kündigung der Lizenz fort.

7. Lizenzvergütung

7.1 Sie sind verpflichtet nach Lieferung/Installation der Software an Utimaco die Lizenzgebühren als Pauschalzahlung wie separat zwischen den Parteien vereinbart („Lizenzvergütung") sowie alle etwaigen Steuern zu zahlen.

7.2 Die Lizenzvergütung sowie etwaige Steuern werden Ihnen von Utimaco in Rechnung gestellt und Sie sind verpflichtet innerhalb von dreißig (30) Tagen die Rechnung durch Geldüberweisung auf ein Konto von Utimaco zu überweisen. Die Verzugszinsen belaufen sich auf 10% per annum.

8. Gewährleistung

8.1 Utimaco leistet Gewähr dafür, dass die Software im Sinne der von Utimaco herausgegebenen und zum Zeitpunkt des Downloads gültigen Programmbeschreibung unter normalen Betriebsbedingungen und bei normaler Instandhaltung brauchbar ist. Eine unerhebliche Minderung der Brauchbarkeit bleibt außer Betracht. Utimaco gewährleistet nicht, dass die Software insgesamt fehlerfrei oder ununterbrochen ist oder sein wird, und Utimaco schließt - soweit gesetzlich möglich - jegliche Haftung aus diesem Grunde aus. Utimaco haftet für keinen Anspruch nach diesem Artikel 8, der gegenüber Utimaco nicht innerhalb von sechzig (60) Tagen nach dem Download der Software geltend gemacht wurde. Erweist sich die Software als nicht brauchbar, wird Utimaco nach Ihrer Wahl, die Software reparieren oder gegen ein neues Programm austauschen oder Ihnen die gezahlten Gebühren erstatten. Sonstige Ansprüche sind ausgeschlossen.

Dies gilt jedoch nur, falls Utimaco innerhalb der Gewährleistungsfrist bei Entdeckung der Mängel durch Sie unverzüglich schriftlich benachrichtigt wird, und wenn die Untersuchung der Software durch Utimaco ergibt, dass diese Mängel tatsächlich bestehen.

Die Gewährleistung ist ausgeschlossen, falls der Mangel verursacht wird durch: (i) die Einbeziehung, das Anfügen oder den Einsatz eines Zusatzes, einer Funktion, eines Programms oder Geräts in die oder mit der Software oder eines Teiles derselben, das nicht von Utimaco stammt; (ii) Unfall, Transport, Nachlässigkeit oder Missbrauch; (iii) Änderung, Modifikation oder Verbesserung der Software außer durch Utimaco; (iv) Gebrauch der Software außer für den vorgesehenen Zweck; (v) Gebrauch der Software auf Systemen außer der spezifizierten Hardware-Plattform für diese Software; (vi) Ihren Gebrauch defekter Medien oder fehlerhafter Duplizierung der Software; oder (vii) Ihre Versäumnis ein früher von Utimaco geliefertes Update zur Korrektur einer solchen Abweichung zu installieren. JEDE RÜCKERSTATTUNG VON GEBÜHREN GILT ALS KÜNDIGUNG DIESER VEREINBARUNG (UND JEGLICHER DAMIT ZUSAMMENHÄNGENDEN WARTUNGSVEREINBARUNG) UND IST IHR EINZIGES UND AUSSCHLIESSLICHES RECHT BEI EINEM GEWÄHRLEISTUNGSFALL. WEITERGEHENDE GEWÄHRLEISTUNGSANSPRÜCHE BESTEHEN NICHT.

8.2 AUSSER DEN AUSDRÜCKLICHEN, BEGRENZTEN GEWÄHRLEISTUNGEN IN DIESEM ARTIKEL 8, GIBT WEDER UTIMACO NOCH EINER IHRER DISTRIBUTOREN ODER WIEDERVERKÄUFER AUSDRÜCKLICH, KONKLUDENT (TATSÄCHLICH ODER GESETZLICH) ODER IN KOMMUNIKATION MIT IHNEN BEZÜGLICH DER SOFTWARE ODER EINER IN VERBINDUNG DAMIT GELIEFERTEN LEISTUNG GEWÄHRLEISTUNGEN AB, UND UTIMACO SCHLIESST AUSDRÜCKLICH ALLE KONKLUDENTEN GEWÄHRLEISTUNGEN ODER BEDINGUNGEN AUS, EINSCHLIESSLICH DER RECHTSFREIHEIT, VERKÄUFLICHKEIT, VERSTOSSFREIHEIT UND EIGNUNG FÜR EINEN BESTIMMTEN ZWECK.

8.3 Sie erkennen an, dass Sie, wie zwischen sich selbst und Utimaco, allein verantwortlich sind für Ihre Beziehungen zu dritten Wiederverkäufern der Software. Somit verzichten Sie hiermit auf jeden Anspruch oder Klagegrund gegen oder durch solche Wiederverkäufer, die sich auf Utimaco oder die Software beziehen oder damit in Zusammenhang stehen. Alle solchen Ansprüche sind gemäß Artikel 10 ausgeschlossen.

8.4 Sie erkennen weiterhin an und stimmen zu, dass Sie allein verantwortlich sind für eine ordnungsgemäße Sicherung aller in der Software gespeicherten Daten, und dass Sie Maßnahmen ergreifen müssen, welche dieses sicherstellen. Utimaco übernimmt keinerlei Haftung oder Verantwortung für den Verlust von Daten.

9. Schutzrechte Dritter

9.1 Vorausgesetzt, dass Sie die Software nach Maßgabe dieser Lizenzbedingungen genutzt haben, verpflichtet sich Utimaco nach eigenem Ermessen, jegliche Forderung eines Dritten gegen Sie wegen Verletzung eines gewerblichen Schutzrechts Dritter durch die Software abzuwehren oder zu regeln und Sie von allen Ihnen gerichtlich aufgrund einer solchen Forderung auferlegten Kosten freizustellen. Sie stimmen zu, dass Utimaco von der vorstehenden Pflicht befreit wird, wenn Sie nicht alle angemessenen Schritte zur Minderung etwaiger Kosten ergriffen haben, und Sie Utimaco (a) unverzüglich über eine solche Forderung oder Klage, oder der Möglichkeit derselben schriftlich informiert haben; (b) die alleinige Kontrolle und Vollmacht für die Abwehr oder Regelung einer solchen Forderung oder Klage geben; und (c) ordnungsgemäße und vollständige Informationen und Unterstützung zur Regelung und/oder Abwehr einer solchen Forderung oder Klage geben. Wenn Utimaco nach eigenem Ermessen der Auffassung ist, dass wahrscheinlich eine Verfügung beantragt wird, welche den Gebrauch der Software durch Sie verbietet, so darf Utimaco nach eigenem Ermessen und auf eigene Kosten entweder: (i) für Sie das Recht zum Gebrauch der Software wie hierin vorgesehen beschaffen, (ii) die Software durch gleichwertige nicht die Rechte Dritter verletzende Software ersetzen; (iii) die Software so ändern, dass der Verstoß beseitigt wird; oder (iv) die Rückgabe der Software verlangen und die von Ihnen an Utimaco gezahlten Gebühren abzüglich einer angemessenen Nutzungsentschädigung für die Dauer der Nutzung bis zur Rückgabe der Software erstatten, die der Software zugeordnet werden können, und diese Vereinbarung kündigen. Bei Ausübung des Rechts gemäß (iv) des letzten Satzes hat Utimaco Ihnen gegenüber keine weiteren Pflichten oder Haftung. Außer wie vorstehend festgelegt haftet Utimaco für keine Kosten oder Auslagen, die ohne ihre vorherige Genehmigung entstanden sind.

9.2 Unbeschadet der Bestimmungen von Artikel 9.1 übernimmt Utimaco keine Haftung für alle und jegliche Forderungen, die sich ergeben aus (i) der Kombination der Software mit anderen Produkten, die nicht von Utimaco geliefert wurden; (ii) allen Änderungen der Software, wenn diese Änderung nicht von Utimaco vorgenommen wurden; (iii) Gebrauch der Software, wenn die Verletzung vermieden worden wäre, sofern die Software in Übereinstimmung mit der Dokumentation verwendet worden wäre; (iv) nicht genehmigtem Gebrauch des geistigen Eigentums von Utimaco, oder (v) Software von Dritten, die in die Software einbezogen wurde.

9.3 DIE VORSTEHENDEN BESTIMMUNGEN DIESES ARTIKELS 9 STELLEN DIE GESAMTE HAFTUNG UND VERPFLICHTUNGEN VON UTIMACO IM FALLE EINER TATSÄCHLICHEN ODER BEHAUPTETEN VERLETZUNG EINES PATENTS, URHEBERRECHTS, BETRIEBSGEHEIMNISSES, WARENZEICHENS ODER ANDEREN GEWERBLICHEN SCHUTZRECHTEN DURCH DIE SOFTWARE ODER EINES TEILES DERSELBEN DAR. SONSTIGE GEWÄHRLEISTUNGSANSPRÜCHE BESTEHEN NICHT.

9.4 Auf Verlangen von Utimaco entschädigen Sie Utimaco und stellen Utimaco frei von und gegen alle Forderungen, Haftungen, Verluste, Schäden, Auslagen und Kosten (einschließlich Anwaltshonorare und Kosten) hinsichtlich Verletzung oder widerrechtlicher Aneignung von geistigen Eigentumsrechten, soweit in Artikel 9.1 nichts anderes geregelt ist.

10. Haftungsbeschränkung

10.1 MIT AUSNAHME VON ANSPRÜCHEN GEMÄSS ARTIKEL 9 HINSICHTLICH SCHUTZRECHTER DRITTER IST DIE GESAMTHAFTUNG VON UTIMACO GEGENÜBER IHNEN UND EINEM DRITTEN, DIE SICH AUS ODER IN VERBINDUNG MIT DIESER VEREINBARUNG ERGIBT, (UNABHÄNGIG VOM RECHTSGRUND UND HAFTUNGSTHEORIEN) AUF DIE VON IHNEN FÜR DIE SOFTWARE BEZAHLTEN BETRÄGE BESCHRÄNKT.

10.2 MIT AUSNAHME VON ANSPRÜCHEN WEGEN VERLETZUNG VON UTIMACOS (ODER SEINER LIZENZGEBER) GEISTIGEN EIGENTUMSRECHTEN DURCH SIE HAFTET KEINE PARTEI DER ANDEREN PARTEI ODER EINEM DRITTEN FÜR VERMÖGENSSCHÄDEN, STRAFSCHADENSERSATZ, INDIREKTE, MITTELBARE ODER FOLGESCHÄDEN, EINSCHLIESSLICH UND OHNE DARAUF BESCHRÄNKT ZU SEIN, SCHÄDEN DURCH ENTGANGENEN GEWINN, DATENVERLUST ODER KOSTEN DER BESCHAFFUNG VON ERSATZGÜTERN, TECHNOLOGIE ODER DIENSTLEISTUNGEN, DIE SICH AUS ODER IN VERBINDUNG MIT DIESER VEREINBARUNG ODER DER NUTZUNG DER SOFTWARE ERGEBEN, GLEICHGÜLTIG OB SICH DIESE HAFTUNG AUS EINEM VERTRAG, GARANTIE, DELIKT (EINSCHLIESSLICH FAHRLÄSSIGKEIT), PRODUKTHAFTUNG ODER ANDERWEITIG ERGIBT, UND ZWAR AUCH WENN IM VORAUS AUF DIE MÖGLICHKEIT DIESES VERLUSTES ODER SCHADENS HINGEWIESEN WURDE. DIESE BESCHRÄNKUNGEN GELTEN UNGEACHTET DES VERSAGENS DES WESENTLICHEN ZWECKS EINER BESCHRÄNKTEN ABHILFE. AUF KEINEN FALL HAFTET UTIMACO FÜR ZUSICHERUNGEN ODER GEWÄHRLEISTUNGEN, WELCHE SIE EINEM DRITTEN GEGEBEN HABEN, ODER FÜR FORDERUNGEN, DIE DIREKT ODER INDIREKT BEZOGEN SIND AUF VON IHNEN ERSTELLTE, ZUKÜNFTIGE ÄNDERUNGEN, VERBESSERUNGEN, UPDATES, REVISIONEN UND/ODER NEUE VERSIONEN DER SOFTWARE. BEIDE PARTEIEN ERKENNEN HIERMIT AUSDRÜCKLICH AN, DASS DIE LIZENZGEBÜHR DIE VERTEILUNG DES RISIKOS NACH DIESEM ARTIKEL 10 REFLEKTIERT.

10.3 Die vollständige oder teilweise Ungültigkeit eines der vorstehenden Absätze beeinträchtigt nicht den Rest dieser Klausel oder einer anderen Klausel dieser Vereinbarung. Die von Utimaco hiernach zu erhaltende Vergütung beinhaltet keine Entschädigung für die Kosten der Versicherung von Risiken und Haftungen, die von Utimaco ausgeschlossen werden. Die Beschränkungen und Ausschlüsse der Pflichten und Haftungen von Utimaco sollen im vollsten nach dem Gesetz erlaubten Maße gelten, und die Ungültigkeit der Anwendung derselben auf einen gegebenen Umstand beeinträchtigt diese Anwendung auf einen anderen Umstand nicht. Die Beschränkungen und Ausschlüsse sollen Vorrang vor jeder gegenteiligen Bestimmung dieser Vereinbarung haben.

11. Allgemeines

11.1 Geltendes Recht. Diese Vereinbarung und die Erfüllung der Leistungen nach dieser Vereinbarung unterliegen ungeachtet der Prinzipien des Kollisionsrechts dem Recht des Bundesstaates New York, so als würde diese Vereinbarung vollständig im Bundesstaat New York erfüllt, mit folgenden Ausnahmen: 1) In Deutschland unterliegen alle Auseinandersetzungen im Zusammenhang mit dieser Vereinbarung und der Erfüllung der Leistungen deutschem Recht und werden der alleinigen Zuständigkeit deutscher Gerichte in Frankfurt/Main unterworfen; 2) im Vereinigten Königreich unterliegen alle Auseinandersetzungen im Zusammenhang mit dieser Vereinbarung und der Erfüllung der Leistungen englischem Recht und werden der alleinigen Zuständigkeit englischer Gerichte unterworfen; 3) in Ländern der Europäischen Union, die nicht unter Nr. 1) oder 2) genannt sind, unterliegen alle Auseinandersetzungen im Zusammenhang mit dieser Vereinbarung und der Erfüllung der Leistungen deutschem Recht und werden der alleinigen Zuständigkeit deutscher Gerichte in Frankfurt/Main unterworfen; 4) in Japan unterliegen alle Auseinandersetzungen im Zusammenhang mit dieser Vereinbarung und der Erfüllung der Leistungen japanischem Recht und werden der alleinigen Zuständigkeit des Tokyo District Gerichts in erster Instanz unterworfen; 5) in allen anderen Ländern, sofern rechtlich zulässig, unterliegen alle Auseinandersetzungen im Zusammenhang mit dieser Vereinbarung und der Erfüllung der Leistungen deutschem Recht und werden der alleinigen Zuständigkeit deutscher Gerichte unterworfen, und wenn dies nicht rechtlich zulässig ist, unterliegen alle Auseinandersetzungen im Zusammenhang mit dieser Vereinbarung und der Erfüllung der Leistungen dem Recht des Landes, in dem die Software erworben wurde. Das Übereinkommen der Vereinten Nationen über Verträge über den internationalen Warenverkehr gilt für diese Vereinbarung nicht. Jede der Parteien verzichtet ausdrücklich auf jedes Recht auf ein Verfahren vor einem Geschworenengericht hinsichtlich Auseinandersetzungen aus dieser Vereinbarung.

11.2 Zuständigkeit, Anwaltshonorare. Jede Auseinandersetzung, die sich aus dieser Vereinbarung ergibt, wird ausschließlich vor den Gerichten von New York City, New York, verhandelt, es sei denn in Artikel 11.1 ist etwas anderes geregelt. In allen Klagen oder Verfahren zur Durchsetzung von Rechten nach dieser Vereinbarung steht der obsiegenden Partei die Erstattung der Kosten und angemessenen Anwaltshonorare durch die andere Partei zu.

11.3 Abtrennbarkeit. Wenn eine Bestimmung dieser Vereinbarung durch ein zuständiges Gericht für ungültig erklärt wird, so bleiben die übrigen Bestimmungen dennoch vollständig in Kraft und die Parteien werden die ungültige Bestimmung durch eine gültige Bestimmung ersetzen, die dem Willen der Parteien so nah wie möglich kommt.

11.4 Kein Verzicht. Wenn es eine der Parteien versäumt, eine der Bestimmungen dieser Vereinbarung zu einem Zeitpunkt durchzusetzen, so gilt dies nicht als Verzicht auf das Recht einer der Parteien, diese Bestimmungen später durchzusetzen.

11.5 Höhere Gewalt. Außer der Verpflichtung, Zahlungen zu leisten, ist die Nichterfüllung einer Partei in dem Maße entschuldigt, in dem die Erfüllung durch Streik, Feuer, Überschwemmung, Handlungen oder Anordnungen oder Beschränkung von Regierungen, Versäumnissen von Lieferanten, oder aus anderen Gründen unmöglich gemacht wird, wenn der Leistungsausfall außerhalb der angemessenen Kontrolle und nicht durch Nachlässigkeit der nichterfüllenden Partei bedingt ist.

11.6 Export-Gesetze. Sie halten sich an alle jeweils gültigen Export-Gesetze und Regelungen der U.S. Regierung und der Regierung des Landes, in dem Sie die Software installieren oder herunterladen, und die sich auf die Software beziehen

11.7 Basis des Handels. Jede Partei erkennt an und stimmt zu, dass die Gewährleistungsausschlüsse sowie Haftungs- und Entschädigungsgrenzen in dieser Vereinbarung materielle, verhandelte Grundlagen dieser Vereinbarung sind, und dass sie bei der Festlegung der Vergütung berücksichtigt und reflektiert sind, die jede Partei für den Abschluss dieser Vereinbarung erhält.

11.8 Obligatorisches Recht. Verbraucher haben gesetzliche Rechte nach geltenden nationalen Gesetzen hinsichtlich des Verkaufs von Gebrauchsgütern. Diese Vereinbarung beeinträchtigt keine gesetzlichen Rechte, die Sie haben, oder Rechte, die nicht ausgeschlossen oder beschränkt werden können, noch Rechte gegen die Person, von der Sie dieses Produkt gekauft haben. Sie dürfen alle gesetzlichen Rechte, die Sie haben, in Ihrer alleinigen Entscheidung geltend machen.

11.9 Gesamte Vereinbarung. Diese Vereinbarung stellt die gesamte, endgültige, vollständige und exklusive Vereinbarung zwischen den Parteien dar und ersetzt alle früheren Vereinbarungen oder Zusicherungen, mündlich oder schriftlich, hinsichtlich dieser Vereinbarung. Diese Vereinbarung darf nicht geändert oder ergänzt werden, außer in einem Schriftstück, das von einem ordnungsgemäß bevollmächtigten Vertreter jeder Partei unterzeichnet ist. Sie bestätigen, dass Sie die in dieser Vereinbarung festgelegten Bedingungen gelesen haben, alle Bedingungen verstehen und zustimmen, an diese gebunden zu sein. Utimacos elektronisch oder anderweitig ordnungsgemäß gespeicherte Kopie dieser Vereinbarung gilt als wahre, komplette, gültige, authentische und durchsetzbare Kopie dieser Vereinbarung. Sie verpflichten sich, die Zulässigkeit oder Durchsetzbarkeit der Utimaco Kopie dieser Vereinbarung in der jeweiligen Fassung für ein aus dieser Vereinbarung entstehendes Verfahren nicht anzufechten. Ihre Annahme und diese Vereinbarung gilt als ebenso gültig wie eine Ausfertigung dieser Vereinbarung durch eine von Hand durch Sie geleistete Unterschrift, und diese Vereinbarung gilt als Erfüllung aller Schriftformanforderungen geltenden Rechts, obwohl diese Vereinbarung elektronisch verfasst und akzeptiert wird. Die Aufzeichnung des Datums, an dem Sie diese Vereinbarung akzeptieren, durch Utimaco sowie das Gültigkeitsdatum zukünftiger Änderungen dieser Vereinbarung sind ein schlüssiger Nachweis für das Datum des Inkrafttretens.

11.10 Mitteilung der eingeschränkten Rechte der US Regierung. Die Software ist nur aufgrund privater Ausgaben entwickelt worden und wird als „kommerzielle Computersoftware" wie in DFARS 252.227-7013 (Oktober 1988), DFARS 252.211-7015 (Mai 1991) oder DFARS 252.227-7014 (Juni 1995), und als „wirtschaftliches Gut" wie in FAR 2.101 (a), DFARS 252.227.-7015 (November 1995) oder FAR 52.227-14 (Juni 1987), oder als „eingeschränkte Computersoftware" wie in FAR 52.227.19 (Juni 1987), jeweils soweit einschlägig, geliefert. Sie haben jeweils nur die Rechte, die nach der einschlägigen FAR oder DFARS - Klausel oder dieser Vereinbarung gewährt werden. Hersteller ist Utimaco Safeware AG, Hohemarkstr. 22, 61440 Oberursel, Deutschland, soweit nicht etwas anderes vereinbart oder in der Bestellung, Auftragsbestätigung, Lieferschein und / oder Rechnung angegeben ist.

Teil 2 - Landesspezifische Bedingungen

DEUTSCHLAND

Die unter Teil 1 aufgeführten folgenden Artikel werden insgesamt durch nachfolgende Bestimmungen ersetzt:

Artikel 8 (Gewährleistung) wird durch folgenden Artikel 8 ersetzt werden:

8. Sachmängel und Aufwandsersatz

8.1 Utimaco gewährleistet, dass die Software bei vertragsgemäßem Einsatz der von Utimaco herausgegebenen Programmbeschreibung entspricht.

Für eine nur unerhebliche Abweichung der Leistungen von Utimaco von der vertragsgemäßen Beschaffenheit bestehen keine Ansprüche wegen Sachmängeln.

Ansprüche wegen Mängeln bestehen auch nicht bei übermäßiger oder unsachgemäßer Nutzung, natürlichem Verschleiß, Versagen von Komponenten der Systemumgebung, nicht reproduzierbaren oder anderweitig durch Sie nachweisbaren Fehlern der Software oder bei Schäden, die aufgrund besondere äußerer Umstände entstehen, die nach dem Vertrag nicht vorausgesetzt sind. Dies gilt auch bei nachträglicher Veränderung oder Instandsetzung durch Sie oder Dritte, außer diese erschwert die Analyse und die Beseitigung eines Sachmangels nicht.

Für Schadensersatz- und Aufwendungsersatzansprüche gilt Artikel 10 ergänzend.

8.2 Ansprüche wegen eines Sachmangels verjähren innerhalb eines Jahres ab Ablieferung oder - wenn Utimaco installiert - mit Abschluss der Installation. Die gesetzlichen Fristen für den Rückgriffsanspruch nach § 478 BGB bleiben unberührt, gleiches gilt soweit das Gesetz gemäß § 438 Absatz 1 Nummer 2 BGB (Bauwerke und Sachen für Bauwerke) längere Fristen vorschreibt, bei einer vorsätzlichen oder grob fahrlässigen Pflichtverletzung von Utimaco, bei arglistigem Verschweigen eines Mangels sowie in den Fällen der Verletzung des Lebens, des Körpers oder der Gesundheit.

Die Bearbeitung einer Sachmangelanzeige von Ihnen durch Utimaco führt nur zur Hemmung der Verjährung, soweit die gesetzlichen Voraussetzungen dafür vorliegen. Ein Neubeginn der Verjährung tritt dadurch nicht ein.

Eine Nacherfüllung (Neulieferung oder Nachbesserung) kann ausschließlich auf die Verjährung des die Nacherfüllung auslösenden Mangels Einfluss haben.

8.3 Sie haben Mängelansprüche nur, wenn gemeldete Mängel reproduzierbar oder anderweitig durch Sie nachweisbar sind.

8.4 Stehen Ihnen Mängelansprüche zu, haben Sie zunächst nur das Recht auf Nacherfüllung innerhalb einer angemessenen Frist. Die Nacherfüllung beinhaltet nach Wahl von Utimaco entweder Nachbesserungen oder die Lieferung einer Ersatzsoftware. Ihre Interessen werden bei einer Wahl angemessen berücksichtigt.

8.5 Schlägt die Nacherfüllung fehl oder ist sie aus anderen Gründen nicht durchzuführen, können Sie unter den gesetzlichen Voraussetzungen die Vergütung mindern, vom Vertrag zurücktreten und/oder Schadens- oder Aufwendungsersatz verlangen.

Sie üben das Ihnen zustehende Wahlrecht für Mängelansprüche innerhalb einer angemessenen Frist aus, in der Regel innerhalb von 14 Kalendertagen.

8.6 Utimaco kann Vergütung seines Aufwandes verlangen, soweit

(a) Utimaco aufgrund einer Meldung tätig wird, ohne das ein Mangel vorliegt, außer Sie konnten mit zumutbarem Aufwand nicht erkennen, dass kein Mangel vorlag oder

(b) eine gemeldete Störung nicht reproduzierbar oder anderweitig durch Sie als Mangel nachweisbar ist oder

(c) zusätzlicher Aufwand wegen nicht ordnungsgemäßer Erfüllung Ihrer Pflichten anfällt.

Artikel 9 (Schutzrechte Dritter) wird durch folgenden Artikel 9 ersetzt werden:

9. Rechtsmängel

9.1 Für Verletzungen von Rechten Dritter durch seine Leistung haftet Utimaco nur, soweit die Leistung vertragsgemäß und insbesondere im vertraglich vorgesehenen Nutzungsumfeld eingesetzt wird.

Utimaco haftet für Verletzungen von Rechten Dritter nur innerhalb der Europäischen Union und des europäischen Wirtschaftsraumes sowie am Ort der vertragsgemäßen Nutzung der Leistung.

9.2 Macht ein Dritter gegenüber Ihnen geltend, dass eine Leistung von Utimaco Ihre Rechte verletzt, benachrichtigen Sie unverzüglich Utimaco. Utimaco und gegebenenfalls dessen Vorlieferanten sind berechtigt, aber nicht verpflichtet, soweit zulässig die geltend gemachten Ansprüche auf deren Kosten abzuwehren.

Sie sind nicht berechtigt, Ansprüche Dritter anzuerkennen, bevor Sie Utimaco angemessen Gelegenheit gegeben haben, die Rechte Dritter auf andere Art und Weise abzuwehren.

9.3 Werden durch eine Leistung von Utimaco Rechte Dritter verletzt, wird Utimaco nach eigener Wahl und auf eigene Kosten

(a) Ihnen das Recht zur Nutzung der Leistung verschaffen oder

(b) die Leistung rechtsverletzungsfrei gestalten oder

(c) die Leistung unter Erstattung der dafür von Ihnen geleisteten Vergütung (abzüglich einer angemessenen Nutzungsentschädigung) zurücknehmen, wenn Utimaco keine andere Abhilfe mit angemessenem Aufwand erzielen kann. Ihre Interessen werden dabei angemessen berücksichtigt.

9.4 Ihre Ansprüche wegen Rechtsmängeln verjähren entsprechend Artikel 8.2. Für Schadensersatz- und Aufwendungsersatzansprüche von Ihnen gilt Artikel 10 ergänzend, für zusätzlichen Aufwand von Utimaco gilt Artikel 8.6 entsprechend.

Artikel 10 (Haftungsbeschränkung) wird durch folgenden Artikel 10 ersetzt:

10. Allgemeine Haftung von Utimaco

10.1 Utimaco haftet Ihnen stets (a) für die von Utimaco sowie seinen gesetzlichen Vertretern oder Erfüllungsgehilfen vorsätzlich oder grob fahrlässig verursachten Schäden, (b) nach dem Produkthaftungsgesetz und (c) für Schäden aus der Verletzung des Lebens, des Körpers oder der Gesundheit, die Utimaco, seine gesetzlichen Vertreter oder Erfüllungsgehilfen zu vertreten haben.

10.2 Utimaco haftet bei leichter Fahrlässigkeit nicht, außer soweit eine wesentliche Vertragspflicht (Kardinalpflicht) verletzt wurde.

Diese Haftung ist bei Sach- und Vermögensschäden auf den vertragstypischen und vorhersehbaren Schaden beschränkt. Dies gilt auch für entgangenen Gewinn und ausgebliebene Einsparungen. Die Haftung für sonstige entfernte Folgeschäden ist ausgeschlossen.

Für einen einzelnen Schadensfall ist die Haftung auf die Lizenzvergütung begrenzt. Für die Verjährung gilt Artikel 8.2 entsprechend. Die Parteien können bei Vertragsabschluss eine weitergehende Haftung gegen gesonderte Vergütung vereinbaren. Die Haftung gemäß Artikel 10.1 bleibt von diesem Absatz unberührt.

10.3 Aus einer Garantiererklärung haftet Utimaco nur auf Schadensersatz, wenn dies in der Garantie ausdrücklich übernommen wurde. Diese Haftung unterliegt bei leichter Fahrlässigkeit den Beschränkungen gemäß Artikel 10.2.

10.4 Bei Verlust von Daten haftet Utimaco nur für denjenigen Aufwand, der für die Wiederherstellung der Daten bei ordnungsgemäßer Datensicherung durch Sie erforderlich ist. Bei leichter Fahrlässigkeit von Utimaco tritt diese Haftung nur ein, wenn Sie unmittelbar vor der zum Datenverlust führenden Maßnahmen eine ordnungsgemäße Datensicherung durchgeführt haben.

10.5 Für Aufwendungsersatzansprüche und sonstige Haftungsansprüche von Ihnen gegen Utimaco gilt Artikel 10.1 bis 10.4 entsprechend.